Bug 245301 - Yet another place for configuration
Summary: Yet another place for configuration
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: xdg-user-dirs   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-22 09:37 UTC by Olaf Fraczyk
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 09:50:01 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Olaf Fraczyk 2007-06-22 09:37:00 UTC
Description of problem:
The configuration is kept in /etc/xdg

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
New directories I would expect to be in /etc/skel. Of course it limits the
localization and recreation upon deletion (BTW. this is ugly).

The right place seems to be gconf. Isn't it what is the gconf for? It will make
it (hopefully) in the future network accessible.

Additional info:

Comment 1 Olaf Fraczyk 2007-06-22 09:57:50 UTC
What happens if you have home directories on NFS and you have different settings
for directory names on terminals? Today I work on WKS1 next day on WKS2 etc.
With gconf accessible through the network it could be possible to sort it out in
the future. But anyway I suppose that the whole idea needs heavy rethinking. I
already added https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=245302.

Comment 2 Alexander Larsson 2007-06-25 09:50:01 UTC
Gconf? This is a cross-desktop standard. And having it in /etc/skel is totally
static an unable to cope with the needs for this.

Comment 3 Olaf Fraczyk 2007-06-25 11:07:24 UTC
If you don't want it to be static then IMO this whole idea is not designed
properly. This will cause more problems than benefits. Sorry.


Regarding Gconf:
Whatever you are thinking about Windows' registry, it enables good support for
policies.
And Linux needs something equivalent for desktop.
As Fedora as it's main desktop environment uses GNOME, I assumed that gconf is
the right choice.
The ultimate solution is one system that serves all desktop environmets and is
network accessible. If it is impossible to have such system for GNOME/KDE and
what comes more into your mind then the only solution is to be GNOME-centric.

The current situation is as being in 50% pregnant :)


Note You need to log in before you can comment on or make changes to this bug.