Bug 245339 - Wrong init script
Summary: Wrong init script
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: tog-pegasus   
(Show other bugs)
Version: rawhide
Hardware: All Linux
low
low
Target Milestone: ---
Assignee: Vitezslav Crhonek
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 247076 (view as bug list)
Depends On: 245335
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-22 14:50 UTC by Michal Marciniszyn
Modified: 2014-02-10 23:03 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-03 11:57:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Marciniszyn 2007-06-22 14:50:54 UTC
+++ This bug was initially created as a clone of Bug #245335 +++

Description of problem:
The tog-pegasus init script returns some incorrect error codes and some parts of
it prevent the correct status command call. 
if [ ! -x $CIMSERVER_BIN ]; then
    echo -n "tog-pegasus $1: $CIMSERVER_BIN not found or not executable.";
    failure;
    exit 1;
fi;
this code should appear in start function section (not before that, as it
prevents status command call) and could be more specific in error code (as 1 is
general error).
Same with this:
        echo "Usage: $0 {start|stop|status|restart|reload|force-reload|try-restart}"
        exit 1
core 3 would be more appropriate.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
When fixing this bug, please obbey our init script guidelines and be sure that
status command is run correctly.
Our guidelines are on following two pages:
http://intranet.corp.redhat.com/ic/intranet/InitscriptsSpec.html
http://intranet.corp.redhat.com/ic/intranet/InitscriptGuidelines.html

For an example of the script that returns the error codes correctly and always
runs status see:
http://devserv.devel.redhat.com/~mmarcini/amd

This bug is tracked by 237789.

-- Additional comment from pm-rhel@redhat.com on 2007-06-22 10:43 EST --
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.

Comment 1 Vitezslav Crhonek 2007-08-30 07:50:04 UTC
*** Bug 247076 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.