Bug 245341 - Volume Control changes with Updated software
Volume Control changes with Updated software
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: gnome-media (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Bastien Nocera
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-22 11:08 EDT by Karl F. Larsen
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-20 16:55:57 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Found fix to bug on my computer (2.43 KB, text/plain)
2007-06-24 11:38 EDT, Karl F. Larsen
no flags Details
This is what a good Alsa Mixer looks like. Notice the tab. (8.88 KB, image/jpeg)
2007-06-24 11:41 EDT, Karl F. Larsen
no flags Details
This is what Alsa Mixer looks like when bad. (16.90 KB, image/jpeg)
2007-06-24 11:42 EDT, Karl F. Larsen
no flags Details
This data is what you asked for. Cute how you get i one call/ (679 bytes, text/plain)
2007-06-25 14:43 EDT, Karl F. Larsen
no flags Details
This is the yum log and shows the rpm version Upgrade applied. (27.57 KB, text/plain)
2007-06-25 14:45 EDT, Karl F. Larsen
no flags Details

  None (edit)
Description Karl F. Larsen 2007-06-22 11:08:57 EDT
Description of problem: ON FC6 without updates the alsa mixer presentation when
Volume Control is used is perfect. After all Updates the alsa mixer presentation
was garbled. The playback tab has a Microphone with a speaker as the output!
This problem has continued to F7 as well


Version-Release number of selected component (if applicable):


How reproducible:
It is easy to reproduce. Load a non-respin of FC6 and see the good alsa mixer.
Apply updates, and see the bad one.

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:
  The update should not have effected the Volume control.

Additional info:
I have checked this on two computers, this old home-made and a new Sony laptop.
The results with FC6 are identical on both computers.
Comment 1 Karl F. Larsen 2007-06-22 13:49:57 EDT
   A couple of things. My full Name is Karl F. Larsen and reside in Las Cruces,
NM USA.

I have this computer with all Updates applied to Fedora Core 6. I have a new
load of this version on my laptop and will be able to rpm or yum or whatever to
help you solve this problem. If you need it.

Karl
Comment 2 Matthew Saltzman 2007-06-22 19:52:54 EDT
Karl (or someone), please change the component to gnome-media or alsa or
something having to do with sound.  Also note that the problem occurs in F7 as well.
Comment 3 Karl F. Larsen 2007-06-23 07:38:08 EDT
   I changed the component that causes the bug but not really certain. The
changes that cause the Alsa Mixer presentation to change appear to be the
gstreamer series of rpm files. I say this because in my experience the FC6 alsa
Mixer display is fine if you don't apply any Updates. 

  After Updates on FC6 and on F7 the Alsa Mixer image is bad. 

Karl
 
Comment 4 Karl F. Larsen 2007-06-24 11:38:55 EDT
Created attachment 157713 [details]
Found fix to bug on my computer
Comment 5 Karl F. Larsen 2007-06-24 11:41:15 EDT
Created attachment 157714 [details]
This is what a good Alsa Mixer looks like. Notice the tab.
Comment 6 Karl F. Larsen 2007-06-24 11:42:28 EDT
Created attachment 157715 [details]
This is what Alsa Mixer looks like when bad.
Comment 7 David Timms 2007-06-25 10:00:07 EDT
Karl: Can you please provide the version numbers of the working and not working
gnome-media package and gnome-volume-control:
rpm -qa gnome-media alsa\* kernel\* gstreamer\*
gnome-volume-control --version
Also, the yum log file might be useful: if you could create attachment and
insert  the relevant parts of:
/var/log/yum.log {root access required to copy the contents to a user file -
then annotate it by inserting a line of text to state "now the capture tab is
displayed/not-displayed in gnome-volume-manager"}. We need to see the
combination of packages for when it works, and when it doesn't. Thanks.
Comment 8 Karl F. Larsen 2007-06-25 14:43:18 EDT
Created attachment 157781 [details]
This data is what you asked for. Cute how you get i one call/
Comment 9 Karl F. Larsen 2007-06-25 14:45:58 EDT
Created attachment 157782 [details]
This is the yum log and shows the rpm version Upgrade applied.
Comment 10 Karl F. Larsen 2007-06-25 18:58:37 EDT
It gets worse. I have been having trouble with the microphone. There appears to
be good speaker output but the mike is disconnected. I have tried the usual with
the switch between one and two and lots of other "maybe" things but I am now
certain the mike has not worked for 4 days.

So this is a problem for my solution. It may not be a solution after all. I have
no idea how to get the mike back. I have FC4 on this same hardware so came up in
that and the mike worked just fine with Skype.

I had Skype working last week before these many changes. 

Karl Larsen
Comment 11 Karl F. Larsen 2007-06-26 08:35:37 EDT
(In reply to comment #10)
> It gets worse. I have been having trouble with the microphone. There appears to
> be good speaker output but the mike is disconnected. I have tried the usual with
> the switch between one and two and lots of other "maybe" things but I am now
> certain the mike has not worked for 4 days.
> 
> So this is a problem for my solution. It may not be a solution after all. I have
> no idea how to get the mike back. I have FC4 on this same hardware so came up in
> that and the mike worked just fine with Skype.
> 
> I had Skype working last week before these many changes. 
> 
> Karl Larsen
> 

    I got email from Skype telling me what to change. I then decided to do a
simple stupid test. I put the mike up close to the speaker and got feedback. I
turned down the mike on the Alsa Mixer and the feedback stopped. So I now know I
have a Skype problem and nothing is wrong with the mike control on the Alsa Mixer.

Comment 12 Bastien Nocera 2007-08-20 07:51:57 EDT
Comment on attachment 157781 [details]
This data is what you asked for. Cute how you get i one call/

Please mark text files as such in the interface, saves us saving and then
opening the saved file.
Comment 13 Bastien Nocera 2007-08-20 07:56:14 EDT
Do you really mean to have an i586 kernel?
Jun 17 22:01:42 Installed: kernel.i586 2.6.20-1.2952.fc6

Does the problem still exist? It's unclear from the bug, as there seems to be
multiple problems being discussed here. Furthermore, it's unclear which versions
of which packages are fixing the problem.
Comment 14 Karl F. Larsen 2007-08-20 08:20:56 EDT
  There is confusion around what is a FIX that allows you to use the volume
control and what is wrong with the same. So let me try again. I am using F7 now
and when I bring up Volume control it comes up in alsa mode and I can adjust
received audio but there is no mike control on the alsa mode. So I switch to the
oss mode and there I can find the mike, and it is always turned off.

The Alsa mixer is not fixed. It has no mike present.

Comment 15 Bastien Nocera 2007-08-20 08:29:59 EDT
(In reply to comment #14)
>   There is confusion around what is a FIX that allows you to use the volume
> control and what is wrong with the same. So let me try again. I am using F7 now
> and when I bring up Volume control it comes up in alsa mode and I can adjust
> received audio but there is no mike control on the alsa mode. So I switch to the
> oss mode and there I can find the mike, and it is always turned off.
> 
> The Alsa mixer is not fixed. It has no mike present.

Could you check that you have mixers like "Capture" and "Input source" selected
in the gnome-volume-control preferences?

Otherwise please attach a screenshot of the preferences dialogue with all the
entries visible, as well as the output of "amixer scontrols".
Comment 16 Karl F. Larsen 2007-08-20 16:55:57 EDT
 I have been working with the Volume control and am now convinced that the
problem is due to my having both a Alsa and Oss volume control. This does not
work well. If I could find out how to turn off the Oss mixer I think the Alsa
mixer will work. 

Note You need to log in before you can comment on or make changes to this bug.