Bug 245371 (Nushio) - Eclipse Hangs Randomly
Summary: Eclipse Hangs Randomly
Status: CLOSED CANTFIX
Alias: Nushio
Product: Fedora
Classification: Fedora
Component: eclipse   
(Show other bugs)
Version: 7
Hardware: i686
OS: Linux
low
urgent
Target Milestone: ---
Assignee: Andrew Overholt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-22 17:47 UTC by Juan Manuel Rodriguez
Modified: 2007-12-06 14:40 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-06 14:40:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Log of errors (1.75 KB, application/octet-stream)
2007-06-22 17:47 UTC, Juan Manuel Rodriguez
no flags Details

Description Juan Manuel Rodriguez 2007-06-22 17:47:28 UTC
Description of problem:
I'm using Java Sun 5 (1.5.012). Eclipse will hang sometimes while compiling,
while other times attempting to open .java or .jsp files. 

I haven't been able to trace the error, but it hangs so often, I figure I could
help trace down the bug. 

Version-Release number of selected component (if applicable):
Fedora Eclipse 3.2.2 with WTP

How reproducible:
Very very often. 

Steps to Reproduce:
1. Open Fedora Eclipse and configure Sun's JRE
2. Use Eclipse as normal
3. Open a JSP file. 

  
Actual results:
Screen will hang. Waiting 30 mins will not solve the error. 

Expected results:


Additional info:
I'm using WTP. Installed from within Eclipse from site:
http://download.eclipse.org/webtools/updates/

Comment 1 Juan Manuel Rodriguez 2007-06-22 17:47:29 UTC
Created attachment 157634 [details]
Log of errors

Comment 2 Andrew Overholt 2007-07-13 14:48:20 UTC
Unfortunately, we can't really support this situation because a) it's being run
with a non-free VM and b) you're using WTP which we don't package :(  A brief
look at the log you attached shows that something's missing JEM which is
provided by the Visual Editor but I doubt that's your problem.

Perhaps you should try an upstream WTP download -- they provide "all in one"
downloads that include all of their dependencies -- and see if your hangs still
occur.  At least then we could see if it's something in our SDK packages that's
causing this.  I doubt it is, but it's not entirely impossible.

Can you provide some details on your machine?  Also, what is in
/usr/share/eclipse/eclipse.ini?  You may try messing with the memory limits in
there (the -Xmx lines).  We don't munge them at all because gij doesn't use
them, but the Sun VM you're using will respect them.

Sorry it took so long to respond.

Comment 3 Juan Manuel Rodriguez 2007-07-13 15:10:55 UTC
I installed Upstream "WTP- All in One", still hangs when loading JSPs, and
sometimes when doing heavy processing. 

Its a lot less frequent though. 

The only thing I had in eclipse.ini was -debug -clean, but I also tried leaving
it empty, and setting the Xmx and Xms lines to 512 and 256. The higher the
number, the more frequently it hanged. 

I have 2 gigs of RAM, so I doubt the error is there. 

Comment 4 Andrew Overholt 2007-07-13 15:14:47 UTC
Since you're using the upstream download and it still hangs, I'd suggest asking
on the WTP newsgroup(s) or filing a bug against them at bugs.eclipse.org.


Note You need to log in before you can comment on or make changes to this bug.