Bug 245397 - [s390] scim-libs gtk2 module prevents gtk2 up/downgrades
[s390] scim-libs gtk2 module prevents gtk2 up/downgrades
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: scim (Show other bugs)
5.0
s390x Linux
low Severity low
: ---
: ---
Assigned To: Jens Petersen
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-22 16:23 EDT by John W. Lockhart
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 20:20:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John W. Lockhart 2007-06-22 16:23:13 EDT
Description of problem:
If scim-libs.s390 is present, gtk2's post scriptlet fails, preventing
successful installation/upgrade of gtk2.

Version-Release number of selected component (if applicable):
RHEL-5-Server/GOLD/s390x/os/Server/scim-libs-1.4.4-39.el5.s390.rpm


How reproducible:
Upgrade gtk2, or install it from scratch -- both s390x and s390 versions --
with scim-libs.{s390,s390x} already present.

Steps to Reproduce:
1.
2.
3.
  
Actual results:
rpm -U s390/gtk2-2.10.4-17.el5.s390.rpm
s390/gtk2-debuginfo-2.10.4-17.el5.s390.rpm
s390/gtk2-devel-2.10.4-17.el5.s390.rpm s390x/gtk2-2.10.4-17.el5.s390x.rpm
s390x/gtk2-debuginfo-2.10.4-17.el5.s390x.rpm
s390x/gtk2-devel-2.10.4-17.el5.s390x.rpm
doRpmCommand-result (1536): /usr/bin/update-gtk-immodules: line 39: 25717
Illegal instruction     /usr/bin/gtk-query-immodules-2.0-64 >$FILE
error: %post(gtk2-2.10.4-17.el5.s390x) scriptlet failed, exit status 132
Cannot load module /usr/lib/gtk-2.0/immodules/im-scim.so:
/usr/lib/libstdc++.so.6: undefined symbol: , version GLIBCXX_3.4
/usr/lib/gtk-2.0/immodules/im-scim.so does not export GTK+ IM module API:
/usr/lib/libstdc++.so.6: undefined symbol: , version GLIBCXX_3.4
error: %post(gtk2-2.10.4-17.el5.s390) scriptlet failed, exit status 1



Expected results:
No troubles updating

Additional info:
See Errata 2007:0549 for additional details.

Workaround:  Delete scim-libs.s390 (okay to keep the .s390x version)
before attempting to upgrade gtk2, and restore it afterwards.
e.g.:
 rpm -e scim-libs.s390 scim-devel.s390 scim-qtimm.s390
Comment 1 Jens Petersen 2007-06-24 22:19:35 EDT
Jakub, any known problems with GLIBCXX_3.4 symbol for s390
or does scim just need to be rebuilt?
Comment 2 Jakub Jelinek 2007-06-25 04:44:40 EDT
No.  Furthermore I can't reproduce this on z204.z900 - neither the SIGILL,
nor the failure.
Comment 3 Michal Babej 2007-06-25 09:24:44 EDT
According to suggested workaround, I tried to restore scim*.s390 after upgrading
gtk2, and it failed.

.qa.[root@s390x-5Server s390]# yum install scim-libs.s390 scim-devel.s390
scim-qtimm.s390

...

Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: scim-libs                    ######################### [1/3] 
Cannot load module /usr/lib/gtk-2.0/immodules/im-scim.so:
/usr/lib/libstdc++.so.6: undefined symbol: , version GLIBCXX_3.4
/usr/lib/gtk-2.0/immodules/im-scim.so does not export GTK+ IM module API:
/usr/lib/libstdc++.so.6: undefined symbol: , version GLIBCXX_3.4
  Installing: scim-devel                   ######################### [2/3] 
  Installing: scim-qtimm                   ######################### [3/3] 

Installed: scim-devel.s390 0:1.4.4-39.el5 scim-libs.s390 0:1.4.4-39.el5
scim-qtimm.s390 0:0.9.4-5
Complete!
Comment 4 Jakub Jelinek 2007-06-25 09:27:18 EDT
If you run
/usr/bin/update-gtk-immodules s390-redhat-linux-gnu
by hand, can you reproduce it too?
If yes, can you rerun it with
LD_DEBUG=all /usr/bin/update-gtk-immodules s390-redhat-linux-gnu
?
rpm -V libstdc++
is ok?
Comment 5 Michal Babej 2007-06-25 09:51:39 EDT
1. /usr/bin/update-gtk-immodules s390-redhat-linux-gnu << yes, same undefined
symbol error.

2. LD_DEBUG=all ... produces a long output... grep "symbol lookup error" gives a
bunch of "undefined symbol: g_module_check_init (fatal)" and "undefined symbol:
g_module_unload (fatal)" for many files in /usr/lib/gtk-2.0/2.10.0/immodules,
and also:
     23015:     /usr/lib/libstdc++.so.6: error: symbol lookup error: undefined
symbol: , version GLIBCXX_3.4 (fatal)

3. rpm -Vv libstdc++ shows changed MD5 for /usr/lib/libstdc++.so.6.0.8
Comment 6 Michal Babej 2007-06-25 10:04:02 EDT
after restoring /usr/lib/libstdc++.so.6.0.8, "/usr/bin/update-gtk-immodules
s390-redhat-linux-gnu" produces no output
Comment 7 Michal Babej 2007-06-25 10:13:14 EDT
gtk2 upgrade/downgrade went without errors (with s390 scim rpms installed), so
did removing & install of scim-*.s390 packages.
Comment 8 Jakub Jelinek 2007-06-25 11:48:51 EDT
Do you have a copy of the broken libstdc++.so.6.0.8?  Was it prelinked or not?
Though if it was properly prelinked rpm -Vv wouldn't complain about md5...
Comment 9 Michal Babej 2007-06-26 05:10:07 EDT
Sorry, no. Though now i discovered that system-config-printer segfaults >>
python segfaults on loading /usr/lib64/python2.4/site-packages/gtk-2.0/pango.so
>> that file has the same verify flags (only MD5 changed)
Comment 10 Jens Petersen 2007-06-26 20:27:18 EDT
Does reinstalling help?
Comment 11 Michal Babej 2007-06-27 10:03:39 EDT
i restored the original pango.so and it works fine. I think we can close this as
notabug... as it clearly has nothing to do with scim/gtk2.
Comment 12 Jens Petersen 2007-10-17 00:10:09 EDT
dropping ack flags

Note You need to log in before you can comment on or make changes to this bug.