Bug 245435 - Rocks and Diamonds violates Fedora Packaging Guidelines
Rocks and Diamonds violates Fedora Packaging Guidelines
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: rocksndiamonds (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Tom "spot" Callaway
Fedora Extras Quality Assurance
:
Depends On:
Blocks: FE-Legal
  Show dependency treegraph
 
Reported: 2007-06-23 02:15 EDT by Exile In Paradise
Modified: 2009-09-21 17:58 EDT (History)
0 users

See Also:
Fixed In Version: 3.2.3-2.fc7.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-15 15:46:56 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Exile In Paradise 2007-06-23 02:15:23 EDT
Description of problem:
ArtSoft and Fedora are distributing sampled loops from copyrighted music by Alan
Parsons, Tangerine Dream, and others, while listing the license as GPL.

When my son began playing this game the other day, I noticed the music straight
away, having physical copies of the Pyramid and Exit albums in my music collection.

However, there was no place I could find in the documentation, website, or
interface that said ArtSoft were licensed to legally include those sample loops,
or redistribute them under the GPL.

I am not the first to make this observation:
http://lists.debian.org/debian-legal/2003/05/msg00544.html

The problematic files in question install to:
/usr/share/rocksndiamonds/music/mus_classic

As a workaround for users who want a pure FOSS Fedora, simply replace the wave
files in that directory with your own, and update the text files as appropriate.

Version-Release number of selected component (if applicable):
rocksndiamonds-3.2.3-1.fc7

How reproducible:
Completely. Install Rocks and Diamonds from F7's RPM, you get copyrighted music
from before there was even a GPL... yet the game is licensed GPL?

Steps to Reproduce:
1. sudo yum install rocksndiamonds
2. rocksndiamonds
3. Choose  "info screen" and "music info", and scroll through the screens
identifying each clip while it plays.
  
Actual results:
Clearly identified music clips from "Network 23" by Tangerine Dream, "Exit" and
Voyager from Alan Parsons "Pyramid" play, and are identified in the interface,
with no clear listing that ArtSoft is licensed to redistribute these clips as GPL.

Expected results:
Fedora packages follow the packaging guidelines:
http://fedoraproject.org/wiki/Packaging/Guidelines especially the section under
"Emulators"

Additional info:
According to the ArtSoft website, the goal of Rocks and Diamonds is to recreate
the look, sounds, and gameplay of several copyrighted games, specifically
Boulder Dash, Emerald Mines, and others.

Regardless of whether the graphics were sourced from those original games, or
created from scratch, this game may qualify as a derivative work under U.S. law. 

If so, I think that may qualifies it as an emulator in any case, whether or not
it included the copyrighted music clips.

I don't think this can ship in Fedora as-is, which is a pity, because my son
loves the game very much and seemed to become instantly hooked on it.

But, maybe it is enough to repackage the game without the problematic music
clips or any problem artwork? 

The game has a level editor and a wide base of user-built levels and contributed
content, which could possibly be distributed with the core code instead of
levels that emulate copyrighted games?
Comment 1 Tom "spot" Callaway 2007-07-09 17:12:51 EDT
Unless the artwork is directly copied from those other games, it is fine, as US
law has upheld that "game look and feel" is OK to copy, as long as it is not an
exact copy, and that copyright/trademarks are not misused.

The music is a much bigger issue, and I've started an effort to either get
permission from the artist or have it replaced with Creative Commons licensed
sound samples.

See:
http://spot.livejournal.com/271177.html

Thank you for bringing this to my attention.
Comment 2 Martin Stransky 2007-07-10 03:49:56 EDT
There's a free music what can be used (fedora.ogg).

http://people.redhat.com/stransky/linda/

It was composed by Martin Linda and it's copyrighted under Creative Commons license.
Comment 3 Fedora Update System 2007-08-15 15:46:50 EDT
rocksndiamonds-3.2.3-2.fc7.1 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.