This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 245446 - ruby header breakage
ruby header breakage
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ruby (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Akira TAGOH
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-23 08:03 EDT by John Ellson
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-26 08:23:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
include node.h in ruby.h before intern.h (235 bytes, patch)
2007-06-23 08:13 EDT, John Ellson
no flags Details | Diff

  None (edit)
Description John Ellson 2007-06-23 08:03:45 EDT
Description of problem:
graphviz builds are failing on fedora development due to an error from ruby
headers.  graphviz uses swig-generated code.

/usr/lib64/ruby/1.8/x86_64-linux/intern.h:207: error: use of enum
'rb_thread_status' without previous declaration
/usr/lib64/ruby/1.8/x86_64-linux/intern.h:207: error: invalid type in
declaration before ';' token
make[3]: *** [gv_ruby.lo] Error 1



Version-Release number of selected component (if applicable):
ruby-devel-1.8.6.36-2.fc8.x86_64

How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 John Ellson 2007-06-23 08:13:14 EDT
Created attachment 157680 [details]
include node.h in ruby.h before intern.h
Comment 2 John Ellson 2007-06-23 08:16:58 EDT
rb_thread_status is defined in node.h, but node.h wasn't being included anywhere
Comment 3 Akira TAGOH 2007-06-25 02:41:41 EDT
Should be fixed in 1.8.6.36-3.fc8
Comment 4 John Ellson 2007-06-25 11:54:10 EDT
Yes.  Works for me.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.