This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 245461 - g-wrap-ffiexecstack.patch breaks g-wrap build on arm
g-wrap-ffiexecstack.patch breaks g-wrap build on arm
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: g-wrap (Show other bugs)
rawhide
arm9 Linux
low Severity low
: ---
: ---
Assigned To: Bill Nottingham
Fedora Extras Quality Assurance
:
Depends On:
Blocks: ARMTracker
  Show dependency treegraph
 
Reported: 2007-06-23 12:08 EDT by Lennert Buytenhek
Modified: 2014-03-16 23:07 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 12:37:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Lennert Buytenhek 2007-06-23 12:08:04 EDT
The g-wrap-ffiexecstack.patch which Fedora ships breaks the build on arm
because '@' starts a comment in ARM assembler, and the execstack diff adds
the following line to libffi/src/arm/sysv.S:

+       .section        .note.GNU-stack,"",@progbits

Changing @progbits to %progbits fixes the build.  Could you please apply
this change?

Thanks for your time.
Comment 1 Bill Nottingham 2007-06-25 12:37:26 EDT
Fixed in CVS. Note that g-wrap is going away soon.

Note You need to log in before you can comment on or make changes to this bug.