Bug 245476 - xfs update comes with a mystery line in /etc/X11/fs/config
Summary: xfs update comes with a mystery line in /etc/X11/fs/config
Status: CLOSED DEFERRED
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11-xfs   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Kristian Høgsberg
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: EasyFix
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-23 20:08 UTC by Michal Jaegermann
Modified: 2018-04-11 17:36 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 23:03:40 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2007-06-23 20:08:30 UTC
Description of problem:

The current update of xfs produces /etc/X11/fs/config.rpmnew file
in which one can find:

# where to look for fonts
catalogue = catalogue:/etc/X11/fontpath.d

The problem is that neither 'man xfs' nor anything in 
/usr/share/doc/xorg-x11-xfs-1.0.4/ documents what that may be.

A name like "/etc/X11/fontpath.d" suggests that this is possibly
a directory but nothing provides such file or directory
nor even any examples which would suggest how to replace
an old "catalogue =" with this new format.  Even if such
suggestions would exist a documentation would be more than
welcome.

Version-Release number of selected component (if applicable):
xorg-x11-xfs-1.0.4-1

Comment 1 Matěj Cepl 2007-06-25 12:59:33 UTC
Missing documentation, see
http://lists.freedesktop.org/archives/xorg/2007-June/025803.html for example of
patch.

Comment 2 Michal Jaegermann 2007-06-25 15:32:41 UTC
> Missing documentation
Right you are, but not only.  It looks like that a directory
/etc/X11/fontpath.d should exist and it should be owned by
xorg-x11-xfs package.  It is "missing small spec mods" too.

Comment 3 Kristian Høgsberg 2007-06-25 23:03:40 UTC
We need some mystery now and then.  The fontpath.d directory is created and
owned by the xorg font packages.  While the code changes are int libXfont, the
man pages for the X server and the font server is what needs updates.  We'll
pull them down when we update them.


Note You need to log in before you can comment on or make changes to this bug.