Bug 245480 - firefox "application" font messed up
firefox "application" font messed up
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: firefox (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
FF3RawhideClose
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-23 17:12 EDT by Michal Jaegermann
Modified: 2007-12-20 11:48 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-20 11:48:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
a fragment of a display showing "the same" font in firefox and elsewhere (4.50 KB, image/png)
2007-06-23 17:12 EDT, Michal Jaegermann
no flags Details

  None (edit)
Description Michal Jaegermann 2007-06-23 17:12:25 EDT
Description of problem:

A series of quick experiments indicates that in menus, toolbars,
similar and, the most essential, URL display firefox is using what
in preferences is called "Application Font".  Well, not exactly.
For example making this font bold is causing a switch to bold
in those mentioned places in firefox too but if you will do that with
italics then this is ignored although in other locations, outside
of firefox, fonts do change.

What is much more important is that firefox scales down font sizes
making them unreadable for those who has troubles with vision.
You can push up a font size making those accepteble in firefox but
then "the same" font used in menus, on a panel, and elsewhere becomes
ridiculously big creating other problems.  Is there a really
good reason for firefox to use "private" font rendering thus
creating a loose-loose situation?

Version-Release number of selected component (if applicable):
firefox-2.0.0.4-2.fc8
Comment 1 Michal Jaegermann 2007-06-23 17:12:25 EDT
Created attachment 157699 [details]
a fragment of a display showing "the same" font in firefox and elsewhere
Comment 2 Michal Jaegermann 2007-10-30 16:02:02 EDT
With the current firefox from rawhide I see the same size font
used in menu bars or menus as in similar elements in other places.
Is this the case for everybody?  I have an impression, maybe not
correct, that something funny is going on here.
Comment 3 Matěj Cepl 2007-12-20 11:48:07 EST
We just updated the Firefox version in Fedora/development from 2.0 to a 3.0
pre-release version, which improves performance, memory usage, and fixes many
bugs and crashes.

Closing as CANTFIX since we aren't fixing bugs filed against 2.0 now that 3.0 is
in.  If this bug is still present in rawhide using a Firefox 3.0 version, please
re-open this bug.

Thanks and Happy Holidays

Note You need to log in before you can comment on or make changes to this bug.