Bug 245508 - USB drv does not auto mount and does show on desktop in kde
Summary: USB drv does not auto mount and does show on desktop in kde
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: hal   
(Show other bugs)
Version: 7
Hardware: i386
OS: Linux
low
low
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-24 17:21 UTC by vikram goyal
Modified: 2013-03-06 03:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-02 17:39:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lshal autput before attaching usb drv (127.82 KB, text/plain)
2007-06-27 13:34 UTC, vikram goyal
no flags Details
lshal after attaching usb drv (138.26 KB, text/plain)
2007-06-27 13:36 UTC, vikram goyal
no flags Details

Description vikram goyal 2007-06-24 17:21:43 UTC
Description of problem:
I have udev-106-4.fc7 installed. I have 1GB flash with boot files from F7
and it does not mount at all , something to do with ext3 I think.

Version-Release number of selected component (if applicable):
udev-106-4.fc7

How reproducible:


Steps to Reproduce:
1.plug in an usb stick 
2.
3.
  
Actual results:
no icon for usb stick on desktop

Expected results:


Additional info:
[root@f7host ~]# lsusb
Bus 002 Device 003: ID 051d:0002 American Power Conversion Back-UPS Pro
500/1000/1500
Bus 002 Device 001: ID 0000:0000
Bus 004 Device 001: ID 0000:0000
Bus 005 Device 003: ID 13fe:1d00
Bus 005 Device 001: ID 0000:0000
Bus 003 Device 001: ID 0000:0000
Bus 001 Device 001: ID 0000:0000

------------------------------------------------------

Jun 24 21:59:48 f7host kernel: usb 5-1: new high speed USB device using ehci_hcd
and address 3
Jun 24 21:59:48 f7host kernel: usb 5-1: configuration #1 chosen from 1 choice
Jun 24 21:59:48 f7host kernel: Initializing USB Mass Storage driver...
Jun 24 21:59:48 f7host kernel: scsi4 : SCSI emulation for USB Mass Storage devices
Jun 24 21:59:48 f7host kernel: usbcore: registered new interface driver usb-storage
Jun 24 21:59:48 f7host kernel: USB Mass Storage support registered.
Jun 24 21:59:53 f7host kernel: scsi 4:0:0:0: Direct-Access     Kingston
DataTraveler 2.0 PMAP PQ: 0 ANSI: 0 CCS
Jun 24 21:59:53 f7host kernel: SCSI device sdc: 2015232 512-byte hdwr sectors
(1032 MB)
Jun 24 21:59:53 f7host kernel: sdc: Write Protect is off
Jun 24 21:59:53 f7host kernel: sdc: assuming drive cache: write through
Jun 24 21:59:53 f7host kernel: SCSI device sdc: 2015232 512-byte hdwr sectors
(1032 MB)
Jun 24 21:59:53 f7host kernel: sdc: Write Protect is off
Jun 24 21:59:53 f7host kernel: sdc: assuming drive cache: write through
Jun 24 21:59:53 f7host kernel:  sdc: sdc1
Jun 24 21:59:53 f7host kernel: sd 4:0:0:0: Attached scsi removable disk sdc
Jun 24 21:59:53 f7host kernel: sd 4:0:0:0: Attached scsi generic sg3 type 0

----------------------------------------------------------------

Does not show on desktop, also not in mount command

Comment 1 Harald Hoyer 2007-06-26 12:32:39 UTC
udev does not automount..

Comment 2 David Zeuthen 2007-06-26 15:41:45 UTC
> Does not show on desktop, also not in mount command

What does this mean? Try this and paste the output

 1. as root: 'mount /dev/sdc1 /mnt' 
 2. as your own user: 'gnome-mount -t -v -d /dev/sdc1'

Also attach output of 'lshal' thanks. 

Comment 3 vikram goyal 2007-06-27 13:34:53 UTC
Created attachment 158003 [details]
lshal autput before attaching usb drv

Comment 4 vikram goyal 2007-06-27 13:36:43 UTC
Created attachment 158004 [details]
lshal after attaching usb drv

Comment 5 vikram goyal 2007-06-27 13:37:22 UTC
I am not using gnome but kde.

I have attached lshal output before and after connecting USB drv.

My point was that it should get auto mounted or a window should come up,
possibly controlled by hald, I'm not sure, with required action to be
taken.

I have mounted the fs successfuly before also, the point was that it
should be automatic, since I cannot as a user mount anything and have to
su - to do the stuff and make ownership etc sane for a normal user to work
upon the filesystem. I have checked this with ext3 as well as fat16 fs
because I first thought that due to ext3 fs this was happening. In Fc6
the behaviour was normal.

Let me know if any other info is needed.

Comment 6 David Zeuthen 2007-06-27 15:15:31 UTC
(In reply to comment #5)
> I am not using gnome but kde.
> 
> I have attached lshal output before and after connecting USB drv.
> 
> My point was that it should get auto mounted or a window should come up,
> possibly controlled by hald, I'm not sure, with required action to be
> taken.

That's why I'm asking you to try gnome-mount to see if it's a KDE problem or if
GNOME is also affected. Again, please try 'gnome-mount -t -v -d /dev/sdc1'

You can install gnome-mount by installing the RPM of the same name. Thank.

      David


Comment 7 vikram goyal 2007-06-29 17:15:59 UTC
I updated to dbus.i386 1.0.2-6.fc7, dbus-devel.i386 1.0.2-6.fc7, dbus-x11.i386
1.0.2-6.fc7 and the issue is solved, thanks!

Comment 8 David Zeuthen 2007-07-02 17:39:29 UTC
Closing then


Note You need to log in before you can comment on or make changes to this bug.