Bug 245521 - constantly hits System.MissingMethodException for Evolution.CalUtil.FreeGlueCompGLibSList
Summary: constantly hits System.MissingMethodException for Evolution.CalUtil.FreeGlueC...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: beagle (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: x86_64 Linux
low
low
Target Milestone: ---
Assignee: Alexander Larsson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-24 22:05 UTC by David Nielsen
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version: beagle-0.2.18-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-21 05:43:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Beagle log (1.53 KB, text/plain)
2007-06-24 22:05 UTC, David Nielsen
no flags Details
Beagle Exception log (1.23 KB, text/plain)
2007-06-24 22:06 UTC, David Nielsen
no flags Details
screenshot of beagle on Fedora rawhide desktop running ok. (405.80 KB, image/png)
2007-07-03 21:20 UTC, Valent Turkovic
no flags Details

Description David Nielsen 2007-06-24 22:05:42 UTC
Description of problem:
Whenever I start up Beagle it will idle for a bit then bomb out with a logged
message that:

20070624 23:54:04.2711 32131 Beagle ERROR EX: System.MissingMethodException:
Method not found: 'Evolution.CalUtil.FreeGlueCompGLibSList'.

Version-Release number of selected component (if applicable):
beagle-0.2.17-1.fc8

How reproducible:
100%

Steps to Reproduce:
1. Start beagle
2. wait
  
Actual results:
exception thrown

Expected results:
indexing joy

Additional info:

Comment 1 David Nielsen 2007-06-24 22:05:42 UTC
Created attachment 157725 [details]
Beagle log

Comment 2 David Nielsen 2007-06-24 22:06:22 UTC
Created attachment 157726 [details]
Beagle Exception log

Comment 3 Valent Turkovic 2007-07-03 14:20:24 UTC
I see that this bug is reported for 64bit platform, so does beagle work ok in
32bit rawhide?

ps. how do I continue using rawhide. I had rawhide installed (Fedora 7 test 4)
but once Fedora 7 came out it switched it self to official fedora 7 repositories.
What do I need to do in order to get "rawhide" version of Fedora and test these
bugs under 32bit?

Comment 4 Joe Shaw 2007-07-03 15:12:59 UTC
I think this was reported upstream too.  This appears to be an evolution-sharp
problem -- they removed API without bumping up the interface number.

It can be worked around (for now) by patching out the call to
"CalUtil.FreeGlueCompGLibSList (IntPtr.Zero)" in
beagled/EvolutionDataServerQueryable.cs:ConnectToEDS().

Now to give the evo-sharp maintainer a tongue lashing about APIs and interface
numbers...

Comment 5 Joe Shaw 2007-07-03 15:13:56 UTC
Upstream bug is http://bugzilla.gnome.org/show_bug.cgi?id=452494

Comment 6 Valent Turkovic 2007-07-03 21:19:18 UTC
I have updated Fedora test 4 to latest rawhide and beagle works just fine. Check
out the screenshot. I do get an strange output from beagle-info but it works
just fine.

$ beagle-info --daemon-version

***MEMORY-WARNING***: /usr/lib/beagle/Info.exe[3290]: GSlice: g_thread_init()
must be called before all other GLib functions; memory corruption due to late
invocation of g_thread_init() has been detected; this program is likely to
crash, leak or unexpectedly abort soon...
Daemon version: 0.2.17


Comment 7 Valent Turkovic 2007-07-03 21:20:09 UTC
Created attachment 158477 [details]
screenshot of beagle on Fedora rawhide desktop running ok.

screenshot of beagle on Fedora rawhide desktop running ok.

Comment 8 David Nielsen 2007-08-14 11:46:41 UTC
Our good friend, the wonderful beer-worthy Joe Shaw provided a patch to
workaround this API.. refinement. Could we please apply this to an upcoming
build of Beagle so we might start testing it again in the hopes of avoiding
another last minute disabling.

http://bugzilla.gnome.org/attachment.cgi?id=93599&action=view

Comment 9 David Nielsen 2007-10-21 05:43:39 UTC
beagle-0.2.18-1.fc8 fixes this, closing


Note You need to log in before you can comment on or make changes to this bug.