Bug 245551 - Missing icons in gtkhtml
Summary: Missing icons in gtkhtml
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gtkhtml3   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-25 11:53 UTC by Gilboa Davara
Modified: 2007-11-30 22:12 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-08 03:42:29 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Gilboa Davara 2007-06-25 11:53:48 UTC
Description of problem:
When trying to insert an emoticon (under Evolution, HTML mail, gtkhtml 3.x)
using a known combo (":)", etc) gtkhtml tries to find a matching icons under the
current icon theme (E.g. /usr/share/icons/XXX/16x16/stock/smiley-X.png) which,
in most cases is empty and then tries to use the stock icons that used to be in
/usr/share/gtkhtml3/icons. 
These icons are missing from the current build, resulting in a "missing image"
icon display (instead of the smiley).

Version-Release number of selected component (if applicable):
gtkhtml2-2.11.0-4.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Start evolution.
2. New message.
3. Switch to HTML.
4. Type ":)".
  
Actual results:
1. "Missing image" icon.

Expected results:
1. Smiley.

Comment 1 Matthew Barnes 2007-06-27 03:59:51 UTC
Is this bug supposed to be against gtkhtml2 or gtkhtml3?  I'm guessing gtkhtml3
since you're using it from Evolution, but you indicated gtkhtml2 above.

Many of the icons under /usr/share/gtkhtml3/icons were recently removed because
the same icons are provided by the gnome-icon-theme package.

Comment 2 Gilboa Davara 2007-07-01 11:27:28 UTC
gtkhtml3-3.14.2.

OK, I understand, but it seems that evo/gtkhtml still tries to locate the old
icons (under /usr/share/gtkhtml...) when detecting a smiley combo. (":-)")

- Gilboa

Comment 3 Matthew Barnes 2007-11-08 03:42:29 UTC
I fixed this upstream recently.  GtkHTML was still looking for its old icons in
the code that converts emoticons to images.


Note You need to log in before you can comment on or make changes to this bug.