Bug 245552 - Can't cancel print job waiting in queue
Can't cancel print job waiting in queue
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
6
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-25 07:55 EDT by Dominik 'Rathann' Mierzejewski
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-25 11:22:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CUPS Bugs and Features 2424 None None None Never

  None (edit)
Description Dominik 'Rathann' Mierzejewski 2007-06-25 07:55:02 EDT
Description of problem:
It's impossible to cancel a print job waiting in a remote LPD queue, because
print jobs submitted locally disappear from local queue almost instantly and
CUPS doesn't show remote queue contents like for example LPRng does.

Version-Release number of selected component (if applicable):
1.2.10-3.fc6

How reproducible:
Always.

Steps to Reproduce:
1. Configure local CUPS queue for a remote LPD (LPRng) printer
2. Submit a print job when remote printer is still printing something else
  
Actual results:
The print job disappears from local print queue almost immediately and it's
impossible to cancel it, because CUPS-provided lpq doesn't support remote
LPD-compatible servers.

Expected results:
lpq should either show the submitted job in the local queue until it is
completed or lpq should show remote queue contents and allow their control, per
RFC-1179. If it claims to be a lpq replacement, then it should be compatible.

Additional info:
I would replace CUPS with LPRng, but gtkprint is broken and doesn't show LPR
printers from printcap, like libgnomeprint did.
Comment 1 Tim Waugh 2007-06-25 11:22:38 EDT
Tracking upstream bug report.

Note You need to log in before you can comment on or make changes to this bug.