Bug 245562 - add "--with-f77=gfortran" to configure
add "--with-f77=gfortran" to configure
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: octave (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Quentin Spencer
Fedora Extras Quality Assurance
: EasyFix
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-25 08:47 EDT by Matthew Miller
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-03 10:47:13 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matthew Miller 2007-06-25 08:47:46 EDT
If you have the compat-gcc-34-g77 package installed, octave's configure script
picks g77 in preference to gfortran. Since that's gcc 3.4, it then fails to
build because of gcc4-only parameters in $RPM_OPT_FLAGS.

Putting --with-f77=gfortran ensures that it finds the proper compiler every time.
Comment 1 Quentin Spencer 2007-08-03 10:47:13 EDT
This has been added to 2.9.13 in the development branch.

Note You need to log in before you can comment on or make changes to this bug.