Bug 245567 - Evolution confuses its filter "to folder" settings
Evolution confuses its filter "to folder" settings
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
6
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-25 09:52 EDT by Robert Peterson
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: evolution-2.12.1-1.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-09 20:48:24 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robert Peterson 2007-06-25 09:52:57 EDT
Description of problem:
I set up an evolution filter to move all email with recipient
"Linux-Cluster" to a folder called "linux-cluster".  When I hit
okay, it acknowledged the destination folder was "linux-cluster".
Then I tried to apply filters.  It came up with a message:
Error while filtering folder:
Cannot get folder "linux-cluster list": folder does not exist.
(Despite the fact that I chose the folder from the list it presented).
I went to edit folders and it lists the destination folder as
"linux-cluster list".  I tried to edit the filter and change the
destination folder name back to "linux-cluster" but it did the same
thing.

Version-Release number of selected component (if applicable):
evolution-2.8.3-2.fc6

How reproducible:
Always

Steps to Reproduce:
1. Create a folder called "linux-cluster" for emails.
2. Subscribe to the external linux-cluster mailing list.
3. Wait for a message to arrive in your in-basket from the list.
4. Right-click on the item and select create a filter.
5. Select based on recipient.
6. Select the "linux-cluster" folder.
7. Filter messages
  
Actual results:
Error while filtering folder:
Cannot get folder "linux-cluster list": folder does not exist.

Expected results:
Messages should be filtered.

Additional info:
Comment 1 Matthew Barnes 2007-07-16 12:08:11 EDT
Are you still encountering this problem on Fedora 7?
Comment 2 Robert Peterson 2007-07-16 12:18:22 EDT
I'm not using Fedora 7, I'm on FC6.  I have a dual-monitor setup that
uses propritary drivers that I'm afraid might break on F7.  I need to 
do some research and experiments with F7 before I'll be comfortable 
moving to it.  Right now, with RHEL5.1 so close, I can't afford any
down time at all on my development box to upgrade.
Comment 3 Matthew Barnes 2007-11-07 22:40:02 EST
I tried to reproduce this but the capitalization didn't match the problem
description.  The filter seemed to work for me but I'm not sure I was testing
the problem correctly.

Setting this back to NEEDINFO until Robert can provide an update for F7 or F8.
Comment 4 Robert Peterson 2007-11-09 19:12:43 EST
I upgraded to F8 and this problem seems to have gone away.  So feel
free to close this one.
Comment 5 Matthew Barnes 2007-11-09 20:48:24 EST
Good to hear!  Thanks for the update.

Note You need to log in before you can comment on or make changes to this bug.