Bug 245592 - Errno architecture i386-linux-thread-multi
Errno architecture i386-linux-thread-multi
Status: CLOSED DUPLICATE of bug 294021
Product: Fedora
Classification: Fedora
Component: perl (Show other bugs)
7
i386 Linux
low Severity low
: ---
: ---
Assigned To: Robin Norwood
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-25 12:15 EDT by Jonathan Smith
Modified: 2007-11-30 17:12 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-06 16:15:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Smith 2007-06-25 12:15:21 EDT
Description of problem:

CPAN and CPANPLUS fail. 

Version-Release number of selected component (if applicable):


How reproducible:

Always

Steps to Reproduce:
1.cpan
2.
3.
  
Actual results:

cpan shell -- CPAN exploration and modules installation (v1.7602)
ReadLine support enabled

                                                                                cpan> r
CPAN: Storable loaded ok
Going to read /root/.cpan/Metadata
  Database was generated on Thu, 31 May 2007 19:08:59 GMT
CPAN: LWP::UserAgent loaded ok
Fetching with LWP:
  ftp://ftp.perl.org/pub/CPAN/authors/01mailrc.txt.gz
LWP failed with code[500] message[Errno architecture (i386-linux-thread-multi-2.6.9-
42.0.8.elsmp) does not match executable architecture (i386-linux-thread-multi-2.6.19-
1.2895.fc6xen) at /usr/lib/perl5/site_perl/5.8.8/Errno.pm line 11.
Compilation failed in require at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/IO/
Socket.pm line 17.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.8.8/i386-linux-thread-multi/IO/
Socket.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.8.8/Net/FTP.pm line 18.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.8.8/Net/FTP.pm line 18.
Compilation failed in require at /usr/lib/perl5/site_perl/5.8.8/LWP/Protocol/ftp.pm 
line 24.
]
Fetching with Net::FTP:
  ftp://ftp.perl.org/pub/CPAN/authors/01mailrc.txt.gz
Can't locate object method "new" via package "Net::FTP" at /usr/lib/perl5/5.8.8/
CPAN.pm line 2250.


Expected results:

To be capable of running checkgmail


Additional info:

Have tried removing perl-devel to no avail.
Comment 1 Steven Pritchard 2007-06-25 14:41:21 EDT
CPANPLUS isn't involved here, so I'm reassigning this to the proper component.

Most likely the problem is that you have been using the CPAN shell.  Removing
modules you installed by hand (instead of from rpm packages) will probably fix
the issue.  (Note the /site_perl/ in your error message.  That shouldn't be from
Fedora-supplied packages.)

In the future, if you want a module (say, "Foo::Bar"), try yum first ("yum
install 'perl(Foo::Bar)'").
Comment 2 Jonathan Smith 2007-06-30 13:45:13 EDT
Yes. Same problem occurred on another machine. CPAN and CPANPLUS worked. After
running CPAN and following the suggestion to upgrade CPAN, that system also was
borked, another the problem was slightly different. So , not being a perl guru,
one should avoid using CPAN then. Or, at least avoid install Bundle::CPAN from
the CLI, although it is unclear why then CPAN is made available the distribution.
Comment 3 Alexander Ploumistos 2007-09-11 18:00:22 EDT
Same on x86_64. About a week ago I wanted to install a module from CPAN
(Algorithm::Combinatorics). It was the first time I used the cpan module on this
machine, so I answered all questions it asked me, let it update itself and
install newer versions of core modules. Everything worked fine until today,
during my regular "yum update" routine, I let it install several perl-related
packages, can't recall which. After that, it is impossible to use any of cpan's
functions, I get the following error:

cpan> r
Fetching with LWP:
  ftp://ftp.forthnet.gr/pub/languages/perl/CPAN/authors/01mailrc.txt.gz
LWP failed with code[500] message[Errno architecture
(x86_64-linux-thread-multi-2.6.20-1.2933.fc6xen) does not match executable
architecture (x86_64-linux-thread-multi-2.6.20-1.2962.fc6xen) at
/usr/lib/perl5/site_perl/5.8.8/Errno.pm line 11.
Compilation failed in require at
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/IO/Socket.pm line 17.
BEGIN failed--compilation aborted at
/usr/lib64/perl5/5.8.8/x86_64-linux-thread-multi/IO/Socket.pm line 17.
Compilation failed in require at /usr/lib/perl5/5.8.8/Net/FTP.pm line 18.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.8.8/Net/FTP.pm line 18.
Compilation failed in require at
/usr/lib/perl5/site_perl/5.8.8/LWP/Protocol/ftp.pm line 24.
]
Fetching with Net::FTP:
  ftp://ftp.forthnet.gr/pub/languages/perl/CPAN/authors/01mailrc.txt.gz
Can't locate object method "new" via package "Net::FTP" at
/usr/lib/perl5/5.8.8/CPAN.pm line 2250.
Comment 4 Steven Pritchard 2007-09-11 21:11:58 EDT
(In reply to comment #3)
In a situation like that, you really should just try to build a package.  That
can be as simple as something like this:

  yum install cpanspec
  cpanspec -v -b Algorithm::Combinatorics

If that succeeds, you can install the resulting package.  (It will be in
./x86_64/ in this case.)
Comment 5 Alexander Ploumistos 2007-09-12 08:40:55 EDT
No luck. Look:

# cpanspec -b -v Algorithm::Combinatorics
Errno architecture (x86_64-linux-thread-multi-2.6.20-1.2933.fc6xen) does not
match executable architecture (x86_64-linux-thread-multi-2.6.20-1.2962.fc6xen)
at /usr/lib/perl5/site_perl/5.8.8/Errno.pm line 11.
Compilation failed in require at /usr/lib/perl5/5.8.8/File/Temp.pm line 138.
BEGIN failed--compilation aborted at /usr/lib/perl5/5.8.8/File/Temp.pm line 138.
Compilation failed in require at /usr/lib/perl5/site_perl/5.8.8/Archive/Zip.pm
line 26.
BEGIN failed--compilation aborted at
/usr/lib/perl5/site_perl/5.8.8/Archive/Zip.pm line 26.
Compilation failed in require at /usr/bin/cpanspec line 199.
BEGIN failed--compilation aborted at /usr/bin/cpanspec line 199.
Comment 6 Paul Goffin 2007-09-20 08:24:21 EDT
Since the yum update mentioned in this bug, my system is pretty much hosed. 

The symptoms with CPAN are exactly the same as reported - there is plainly a 
clash with the architecture. 

As a result not only does CPAN not work for me but the RT installation 
this machine is actually used for is now down as apache & RT appear 
to be dependent on perl modules broken by the update.
Comment 7 Paul Goffin 2007-09-20 09:43:59 EDT
FYI.  I've found that editing the file:

/usr/lib/perl5/site_perl/5.8.8/Errno.pm line 11.

And changing line 11 so that the kernel version string matches the installed
kernel I can get my Perl up and working again - CPAN works and my RT system is
back on line.

Obviously this is not a permanent fix but at least my site is back operational.
Comment 8 Sorin Sbarnea 2007-11-06 15:15:39 EST
Switching from simple kernel to kernel-xen or back will bring this bug back. We
need a real solution!
Comment 9 Tom "spot" Callaway 2007-11-06 16:15:12 EST
(In reply to comment #7)
> FYI.  I've found that editing the file:
> 
> /usr/lib/perl5/site_perl/5.8.8/Errno.pm line 11.

You should NOT have this file. This file did NOT come from the Fedora perl package.

[spot@localhost ~]$ rpm -qlp perl-5.8.8-25.fc7.i386.rpm |grep Errno
/usr/lib/perl5/5.8.8/i386-linux-thread-multi/Errno.pm
/usr/share/man/man3/Errno.3pm.gz

Figure out what owns that file, or what placed it there, and you'll know what
caused the bug... but it's not the Fedora perl package.


*** This bug has been marked as a duplicate of 294021 ***

Note You need to log in before you can comment on or make changes to this bug.