Bug 245609 - Unhandled exception during install
Summary: Unhandled exception during install
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: anaconda
Version: 7
Hardware: i386
OS: Linux
low
high
Target Milestone: ---
Assignee: David Cantrell
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-25 18:10 UTC by Joseph Kaye
Modified: 2007-11-30 22:12 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2007-08-22 18:18:35 UTC


Attachments (Terms of Use)
Crash dump from anaconda. (68.95 KB, text/plain)
2007-06-25 18:10 UTC, Joseph Kaye
no flags Details
RAWHIDE/developmental anaconda crashdump. (69.36 KB, text/plain)
2007-06-25 23:47 UTC, Joseph Kaye
no flags Details

Description Joseph Kaye 2007-06-25 18:10:22 UTC
Description of problem: Unhandled exception during install


Version-Release number of selected component (if applicable): Fedora 7


How reproducible: Every time


Steps to Reproduce:
1. Download DVD ISO
2. Unpack to FTP server
3. Burn boot.iso to CD
4: Start installation 
5: After the partition is formatted (/dev/sda15), the unhandled exception is
reported. 
  
Actual results:


Expected results:


Additional info: 
Gigabyte GA-7DPXDW+ motherboard
1GB of RAM
WD 160GB ATA100 Hard Drive
BFGtech gForce MX440 video card
Qlogic QLA2462-CK FC controller (Not connected to SAN)

Comment 1 Joseph Kaye 2007-06-25 18:10:22 UTC
Created attachment 157773 [details]
Crash dump from anaconda.

Comment 2 Joseph Kaye 2007-06-25 23:46:15 UTC
Still fails with the "rawhide" or developmental version.

Comment 3 Joseph Kaye 2007-06-25 23:47:31 UTC
Created attachment 157835 [details]
RAWHIDE/developmental anaconda crashdump.

Comment 4 Joseph Kaye 2007-06-27 21:01:25 UTC
Have you had a chance to look at this yet? Thanks!

Comment 5 Joseph Kaye 2007-07-09 22:33:41 UTC
Any updates to this?

Comment 6 David Cantrell 2007-08-16 20:33:53 UTC
Appears fixed in rawhide.

Comment 7 Joseph Kaye 2007-08-22 18:04:53 UTC
Can you explain why it is still failing on my machine?  Is there any useful
information in the 2 crashdumps that I attached?

Comment 8 David Cantrell 2007-08-22 18:18:35 UTC
Traceback (most recent call first):
  File "/usr/lib/anaconda/partedUtils.py", line 1163, in openDevices
    rc = intf.messageWindow(_("Warning"),
  File "/usr/lib/anaconda/fsset.py", line 118, in createLabel
    diskset.openDevices()
  File "/usr/lib/anaconda/fsset.py", line 581, in labelDevice
    kslabel = entry.label)
  File "/usr/lib/anaconda/fsset.py", line 1550, in labelEntry
    entry.fsystem.labelDevice(entry, chroot)
  File "/usr/lib/anaconda/fsset.py", line 1648, in makeFilesystems
    self.labelEntry(entry, chroot)
  File "/usr/lib/anaconda/packages.py", line 153, in turnOnFilesystems
    anaconda.id.fsset.makeFilesystems (anaconda.rootPath)
  File "/usr/lib/anaconda/dispatch.py", line 203, in moveStep
    rc = stepFunc(self.anaconda)
  File "/usr/lib/anaconda/dispatch.py", line 126, in gotoNext
    self.moveStep()
  File "/usr/lib/anaconda/gui.py", line 1041, in nextClicked
    self.anaconda.dispatch.gotoNext()
  File "/usr/lib/anaconda/iw/progress_gui.py", line 67, in renderCallback
    self.intf.icw.nextClicked()
  File "/usr/lib/anaconda/gui.py", line 1068, in handleRenderCallback
    self.currentWindow.renderCallback()
AttributeError: 'NoneType' object has no attribute 'messageWindow'


Your crash dump shows where anaconda is failing.  We were trying to display an
error message dialog box when the interface object was set to None.  We've fixed
that since you last tried rawhide and now.  Your last crash dump is from June
25th (or posted on that date).  The changelog shows we fixed this issue on July
16th, so a build after that point will have the fix.


Note You need to log in before you can comment on or make changes to this bug.