Bug 245624 - iwlwifi fails to connect to unsecured or open network
iwlwifi fails to connect to unsecured or open network
Status: CLOSED DUPLICATE of bug 242469
Product: Fedora
Classification: Fedora
Component: iwlwifi-firmware (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Matthias Saou
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-25 14:49 EDT by Ian Malone
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-26 18:38:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
/var/log/messages diff before and after attempting to connect (3.19 KB, text/plain)
2007-06-25 14:49 EDT, Ian Malone
no flags Details
Diff dmesg before and after attempting to connect (276 bytes, application/octet-stream)
2007-06-25 14:51 EDT, Ian Malone
no flags Details

  None (edit)
Description Ian Malone 2007-06-25 14:49:52 EDT
Description of problem:
Fails to connect to unsecured networks (ipw3945 driver can be
made to), but will connect to WPA secured network.
May be connected to bug 242469 "NetworkManager will not connect to open wireless
network" https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=242469

Version-Release number of selected component (if applicable):
2.14.3-2

How reproducible:
Have tried GNER and TMobile hotspots, as well as home
router (though that last test may have been confused
by the above NetworkManager bug). 


Steps to Reproduce:
1. Start F7
2. Open NetworkManager applet
3. Select an unsecured network
  
Actual results:
NetworkManager shows that it's attempting to
connect.  After a length of time (order 1 minute),
it gives up the connection attempt.

Expected results:
Connects to the network.

Additional info:
ipw3945 drivers from Freshrpms appear to work
on my local router (after taking bug 242469
into account).  Booting the machine into
Windows worked for GNER and TMobile hotspots.

Medium severity; connecting to hotspots is a
significant use of a wireless chipset.

Please ask if more information required.
Comment 1 Ian Malone 2007-06-25 14:49:52 EDT
Created attachment 157783 [details]
/var/log/messages diff before and after attempting to connect
Comment 2 Ian Malone 2007-06-25 14:51:17 EDT
Created attachment 157784 [details]
Diff dmesg before and after attempting to connect

Dmesg results
Comment 3 Ian Malone 2007-06-26 18:38:00 EDT
Further testing shows I can configure and connect to an open wireless network
with both iwl and ipw drivers using system-config-network, and that neither
driver will reliably connect using NetworkManager (success appears to have been
a fluke). The fault appears to lie in NetworkManager, marking as duplicate of
242469.

*** This bug has been marked as a duplicate of 242469 ***

Note You need to log in before you can comment on or make changes to this bug.