Bug 245639 - RFE: move check-buildroot, check-rpaths to rpm-build or redhat-rpm-config
RFE: move check-buildroot, check-rpaths to rpm-build or redhat-rpm-config
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: redhat-rpm-config (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-25 16:14 EDT by Ville Skyttä
Modified: 2013-01-09 23:21 EST (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-20 18:19:54 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Move check-* to /usr/lib/rpm, add test suite (6.59 KB, patch)
2007-07-02 16:18 EDT, Ville Skyttä
no flags Details | Diff

  None (edit)
Description Ville Skyttä 2007-06-25 16:14:48 EDT
I think it would be a good idea to move check-buildroot and check-rpaths from
rpmdevtools to either rpm (upstream or as distributed by Red Hat) or
redhat-rpm-config.  Reporting against rpm because I believe these scripts are
generic enough to benefit a wider user base than just Fedora/RHEL users.

The scripts are in the /fedora CVS root on cvs.fedora.redhat.com, in
/fedora-rpmdevtools/check-*

http://cvs.fedora.redhat.com/viewcvs/fedora-rpmdevtools/check-buildroot?root=fedora&rev=1.7&view=auto
http://cvs.fedora.redhat.com/viewcvs/fedora-rpmdevtools/check-rpaths?root=fedora&rev=1.4&view=auto
http://cvs.fedora.redhat.com/viewcvs/fedora-rpmdevtools/check-rpaths-worker?root=fedora&rev=1.10&view=auto

For backwards compatibility, it would be nice to have these installed directly
in /usr/lib/rpm/check-* (for which rpm-build sounds better than
redhat-rpm-config to me).  At least check-buildroot could be also enabled by
default in the default rpm-build/redhat-rpm-config configuration - it is already
enabled in all plague and koji build roots as far as I know - by adding it to
%__arch_install_post.

In addition to that these scripts would be available to a wider user base if the
move would be done, one reason driving this is that I'm in the progress of
adding some new goodies with new dependencies to rpmdevtools and don't want that
to result in those dependencies being pulled into minimal build roots.

F-8+ would be a nice time for this change.
Comment 1 Jesse Keating 2007-07-02 15:08:50 EDT
Doing the work to get these into redhat-rpm-config.  Since redhat-rpm-config
will be providing the macro to run these, I think having them in
/usr/lib/rpm/redhat/ is best for now.  This is orthogonal to getting these in
upstream RPM.  If they ever show up in upstream RPM, we can adjust
redhat-rpm-config to drop them and point to the new path for running them.  I
would suggest filing this RFE at rpm.org Trac.
Comment 2 Ville Skyttä 2007-07-02 15:14:56 EDT
The bad thing about /usr/lib/rpm/redhat/ instead of /usr/lib/rpm/ is that a lot
of people and setups have their ~/.rpmmacros and friends configured to invoke
the scripts from /usr/lib/rpm/ - that's where rpmdevtools installs and
rpmdev-setuptree configures them.

I don't think these settings are fixable from a package, therefore /usr/lib/rpm/
would be very much recommended for backwards compatibility and less grief.
Comment 3 Jesse Keating 2007-07-02 15:29:09 EDT
http://people.redhat.com/jkeating/git/redhat-rpm-config.git has changes
necessary to add these files to redhat-rpm-config, and enable them by default.

(also I cleaned up the dist stuff in a second commit)

Jeremy, can you apply this?  This is part of the effort to remove the 'groups'
repo in mock.
Comment 4 Jesse Keating 2007-07-02 15:35:55 EDT
Hrm. a bit of cross traffic there.  I suppose I can make the scripts go into
/usr/lib/rpm, will just mean special casing them in the Makefile, and I do so
hate editing Makefiles :(

Villa, care to provide a patch to Makefile that moves them somewhere different?
Comment 5 Ville Skyttä 2007-07-02 16:18:03 EDT
Created attachment 158375 [details]
Move check-* to /usr/lib/rpm, add test suite

(In reply to comment #4)
> Villa,

That's wool in Finnish :)

> care to provide a patch to Makefile that moves them somewhere different?

Here goes.  Also included is the check suite for check-rpaths from rpmdevtools.
Comment 6 Jesse Keating 2007-07-02 16:52:24 EDT
My git repo now has those changes in it.  Thanks Ville (<-- look, I got it right!)
Comment 7 Panu Matilainen 2007-07-03 01:31:35 EDT
FWIW, I've zero objections to adding the check-* scripts to upstream rpm even
for 4.4.2.1, but enabling by default (or not) will need to go to
redhat-rpm-config at this point.
Comment 8 Jesse Keating 2007-07-03 07:15:50 EDT
How soon would 4.4.2.1 show up?  I'd like to get these things done ASAP as they
are part of a larger change to mock.
Comment 9 Panu Matilainen 2007-07-03 08:14:37 EDT
I can stuff the scripts in, bundle up a 4.4.2.1-rc2 tarball and have it in next
rawhide build if you wish. Final 4.4.2.1 is due out very shortly anyway, these
rc's are simply about being very cautious.
Comment 10 Jesse Keating 2007-07-03 08:31:05 EDT
That would be most awesome.  IF you do that, I'll adjust my redhat-rpm-config
changes to just enable it by default (and fix the %dist stuff too).  Next
rawhide build would be most awesome.
Comment 11 Jesse Keating 2007-07-03 10:24:00 EDT
http://people.redhat.com/jkeating/git/redhat-rpm-config.git now just has changes
for enabling the post %install buildroot checking, and dist cleanups.
Comment 12 Panu Matilainen 2007-07-04 09:21:05 EDT
Added to rpm 4.4.2.1-rc2 and currently building that for rawhide. Assuming
nothing blows up, will be in next rawhide push.
Comment 13 Jesse Keating 2007-07-05 09:26:57 EDT
Confirmed, in the new rpm.  I'll consider this closed.
Comment 14 Ville Skyttä 2007-07-05 16:44:38 EDT
Thanks.  One last bit:

--- scripts/check-rpaths-worker~        2007-07-04 14:57:19.000000000 +0300
+++ scripts/check-rpaths-worker 2007-07-05 23:41:11.000000000 +0300
@@ -65,4 +65,2 @@
 *
-* 'check-rpaths' is part of 'rpmdevtools'.
-*
 *******************************************************************************
Comment 15 Ville Skyttä 2007-07-20 18:19:54 EDT
Looks like Panu got around to fixing that bit in hg some time ago.  Thanks.

Note You need to log in before you can comment on or make changes to this bug.