Bug 245662 - [LSI 5.2 bug] creating a partition on a RHEL 5 ppc64 system causes a kernel page fault.
[LSI 5.2 bug] creating a partition on a RHEL 5 ppc64 system causes a kernel p...
Status: CLOSED WONTFIX
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
ppc64 Linux
low Severity urgent
: rc
: ---
Assigned To: Scott Moser
Martin Jenner
:
Depends On:
Blocks: 217105 425461
  Show dependency treegraph
 
Reported: 2007-06-25 18:36 EDT by Abdel Sadek
Modified: 2009-06-19 19:03 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-19 11:31:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Server RHEL 5.0 /proc/slbinfo /proc/meminfo /proc/cpuinfo (3.39 KB, application/x-zip-compressed)
2007-06-25 18:36 EDT, Abdel Sadek
no flags Details

  None (edit)
Description Abdel Sadek 2007-06-25 18:36:45 EDT
Description of problem:
creating a partition on a RHEL 5 ppc64 system causes a kernel page fault.

Version-Release number of selected component (if applicable):
2.6.18-8.el5
 
How reproducible:
 

Steps to Reproduce:
1. Connect a RHEL 5.0 ppc64 system to a LSI storage array.
2. map 9 volumes of sizes between 1 Gb and 5 Gb.
3.attempt to unregister the device partitions with DM:
  kpartx -d -pp $device
  kpartx -d -p-part $device
  ($device is lun presented from the LSI array)
4. Clear up any previous partition tables: 
   dd if=/dev/zero of=$device bs=16384 count=1 1>/dev/null 2>&1
  ($device is lun presented from the LSI array)
5. make a partition label:
   parted -s $device mklabel msdos 1>/dev/null 2>&1
6. make 4 equal size partitions on each volume:
   my $start = 0;
   my $end = $partSize;
   for(my $i = 0; $i < $partnum; $i++) {
     `parted -s $device mkpart primary $start $end`;
     $start = $end;
     $end = $start + $partSize;
   }
7. all the above steps were included in a script to run on all 9 volumes.
  
Actual results:
when running the script, sometimes the host hangs at begining at the command "dd
if=/dev/zero of=$device bs=16384 count=1 1>/dev/null 2>&1".(step 3).
Sometimes, it passes on the first volume. but it fails at step 3 on the second
volume.
In all cases, the console on the host report the error below:
halfa Unable to handle kernel paging request for data at address 0x00000000
Faulting instruction address: 0xd0000000004680bc


Expected results:


Additional info:
Comment 1 Abdel Sadek 2007-06-25 18:36:45 EDT
Created attachment 157829 [details]
Server RHEL 5.0  /proc/slbinfo /proc/meminfo /proc/cpuinfo
Comment 2 RHEL Product and Program Management 2007-06-26 20:03:54 EDT
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 3 Andrius Benokraitis 2007-07-06 01:52:28 EDT
Scott - does this ppc issue look familiar?
Comment 4 Tom Coughlan 2007-07-09 11:08:46 EDT
Abdel,

I would expect to see an oops message, including a stack trace, after the
"Unable to handle kernel paging request". Please check for this. If there is
none, then force a crash dump after the system hangs and post the resulting info. 

Scott, re-assign as appropriate, based on whatever the stack trace shows. 

Tom
Comment 6 Andrius Benokraitis 2007-08-01 00:56:23 EDT
Haven't heard from Abdel from LSI on this - deferring to 5.2 since we are
already past Beta.

Scott - please re-assign.
Comment 8 Scott Moser 2007-11-07 12:47:05 EST
I'm not really sure who to reassign this to.  Perhaps Tom could do a better job
of re-assigning ?
Comment 10 Andrius Benokraitis 2007-11-08 14:44:49 EST
Abdel, this bugzilla is going to be CLOSED shortly due to lack of response from LSI.
Comment 11 Peter Martuccelli 2007-12-19 11:20:12 EST
No resonse for two update cycles, dev NAK.  Feel free to reopen a new request if
this problem persists in RHEL 5.2.

Note You need to log in before you can comment on or make changes to this bug.