Bug 245665 - dsalib still relies on server root
dsalib still relies on server root
Status: CLOSED CURRENTRELEASE
Product: 389
Classification: Community
Component: Admin (Show other bugs)
1.1.0
All Linux
low Severity low
: ---
: ---
Assigned To: Nathan Kinder
Viktor Ashirov
:
Depends On:
Blocks: 240316 FDS1.1.0
  Show dependency treegraph
 
Reported: 2007-06-25 18:58 EDT by Nathan Kinder
Modified: 2015-12-07 11:40 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2015-12-07 11:40:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
CVS Diffs - First Pass (11.48 KB, patch)
2007-06-25 19:07 EDT, Nathan Kinder
no flags Details | Diff
CVS Commit Message (comment 1 diffs) (2.11 KB, text/plain)
2007-06-25 19:24 EDT, Nathan Kinder
no flags Details
CVS Diffs - Second Pass (21.76 KB, patch)
2007-06-26 13:51 EDT, Nathan Kinder
no flags Details | Diff
CVS Commit Message (comment 3 diffs) (1.74 KB, text/plain)
2007-06-26 14:36 EDT, Nathan Kinder
no flags Details

  None (edit)
Description Nathan Kinder 2007-06-25 18:58:11 EDT
The dsa library in Admin Server still heavily relies on the concept of a server
root.  This library is used by the Directory Server cgi tasks.

The dsa library should try to get paths dynamically from the Directory Server
config when possible.  Other paths that are not in the config, such as the
location of command-line utilities, should be passed in as a define at
compilation time.
Comment 1 Nathan Kinder 2007-06-25 19:07:25 EDT
Created attachment 157833 [details]
CVS Diffs - First Pass

This is a first pass at cleaning up the paths in dsalib.  These changes make
the path getter functions use the Directory Server config values where
possible.
Comment 2 Nathan Kinder 2007-06-25 19:24:33 EDT
Created attachment 157834 [details]
CVS Commit Message (comment 1 diffs)

Checked in changes from comment 1.
Comment 3 Nathan Kinder 2007-06-26 13:51:14 EDT
Created attachment 157923 [details]
CVS Diffs - Second Pass

This pass eliminated the usage of a "server root" in the dsa library.

I also refactored some of the code that was referring to the "install root" as
it did not seem to really represent the directory that it refers to.  I renamed
it to "instance dir" and adjusted the getter function and variables
accordingly.  I needed to pass in the DS libdir as a define for being able to
find the instance dir in the code.

I also found that I was incorrectly using the lockdir config attribute to set
the rundir, which was causing problems for the start, stop, and restart CGIs. 
We don't have the rundir in cn=config by default, but we already have it set as
a PIDDIR define, so I opted to use that instead.  The start, stop, and restart
CGIs now work properly.
Comment 4 Nathan Kinder 2007-06-26 14:36:22 EDT
Created attachment 157931 [details]
CVS Commit Message (comment 3 diffs)

Checked in changes from comment 3.
Comment 5 Yi Zhang 2007-11-28 20:08:23 EST
1. Based on discussion with Noriko. Since DS80 doesn't have the concept of
"ServerRoot". This bug is more relate to code clean up.

2. As in the past we have many cig script relate testing, and there is no
failure relate to "ServerRoot", this bug can be consider as verified. 
Comment 6 Yi Zhang 2007-11-28 20:15:12 EST
All Console functionalities depend on this lib. And console automation test will
rerun next week. If there are any broken function, I will file a new bug. For
now, this bug can be closed. 

Note You need to log in before you can comment on or make changes to this bug.