Bug 245669 - CD Not Found error during installation with DVD
CD Not Found error during installation with DVD
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-25 19:33 EDT by Jeff Stern
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-29 16:32:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Stern 2007-06-25 19:33:39 EDT
Description of problem:
----------------------
When trying to install, I get the "CD Not Found" error message screen
which says,

Version-Release number of selected component (if applicable): 
------------------------------------------------------------
unknown. this is from a DVD created with the "F-7-i386-DVD.iso" iso,
whose SHA1SUM matches.


How reproducible:
-----------------
I have tried to install on 2 i386 boxes, and get the same error with
both machines.


Steps to Reproduce:
------------------
1. Download current F-7-i386-DVD.iso iso.
2. Burn DVD from current F-7-i386-DVD.iso
3. Run checksum SHA1SUM: checks out:

   96b13dbbc9f3bc569ddad9745f64b9cdb43ea9ae  F-7-i386-DVD.iso
4. Install DVD and wait for it to boot up.
5. Choose first choice (install/upgrade) (doesn't matter
   at this point whether one is installing or upgrading: first machine
   was to be an upgrade, other was to be a fresh install. the
   installation process does not get far enough to even deal with this
   difference.)
6. Screen says "loading ata_piix driver"
7. "Choose a Language" screen: choose English
8. "Keyboard Type" screen: choose us
9. Installation method screen

   Screen says:


            Local CDROM
            Hard Drive
            NFS Directory
            FTP
            HTTP

   (here i tried two methods. first doesn't work, 2nd does)

   9a. Choice: Local CDROM

       i. I get the "CD Not Found" screen mentioned in the
       Description, above. The rest of the text reads:

       The Fedora CD was not found in any
       of your CDROMdrives. Please insert
       the Fedora CD and press OK to retry.
               [OK]   [Back]

   9b. Choice: Hard Drive

       Per some suggestions made in some forums, I tried mounting the
       .iso file directly (This file is sitting on a 2nd hard drive
       also on the system.  This works. An

  
Actual results:
---------------
I cannot go any farther in the installation.


Expected results:
-----------------
I expect to get to the "next" screen in the installation (which, when
I chose the hard drive install and provided the location of the .iso
on the 2nd hard disk succeeded and took me to the next screen, which
was "graphical" (starting up the X-Window interface). I did not take
notes on this screen, but i believe it was the screen querying the
user for how/whether to partitioning the hard disk.


Additional info:
----------------
1) I have also seen discussions of this problem at

   http://www.fedoraforum.org/forum/showthread.php?t=156543

and

   http://www.linuxhelpforum.com/showthread.php?t=794751

so it apparently is common, though apparently people do not always
have this problem (because some have installed successfully without
getting it, and also, it has not yet been fixed by Fedora).

2) Given the fact that it is being discussed on the Web, I did try
   searching for this bug in the bugzilla search several times, under
   the anaconda component (and later under any component), and under
   "CD Not Found" and various keywords, such as "DVD not found insert
   retry" etc., but I don't see a similar post. please let me know
   though, if it is a duplicate, and i'm just blind.

3) i wonder if this has anything to do with the new /dev/sd* renaming
   scheme? (just a shot in the dark)

4) hardware configuration

   on both systems i have more than 1 hard drive. 

   on system 1 i have 3 (1 EIDE with boot partition on channel 0, DVD
   drive on channel 1, and 2 more SATA's (on a separate SATA card) in
   a linux software raid configuration for /home directories). this
   system was to be upgraded from FC6 to 7.

   on system 2 i have two EIDE hard drives on channel 0 and the DVD
   drive on channel 1. this system is a fresh install (though drive 2
   used to be drive 1 and does still have fc4 on it (which it ran
   successfully for years).

5) i can be more specific about the hardware info or dmesg errors,
   etc.. just let me know what you need..
Comment 1 Jeff Stern 2007-08-07 17:16:51 EDT
is there anything going on with this bug? it has been over a month, now, and i
have been holding these machines open in case you need me to answer a question
(i see so many bugs go by closed because the original poster didn't respond to a
question from the bug maintainer).. but i can't wait much longer.. i need to get
these machines updated.. thank you.
Comment 2 Chuck Ebbert 2007-08-07 17:30:07 EDT
The bug is probably fixed but you'd need a respin of the install CD and I don't
know if/when there will be one available.
Comment 3 Jarod Wilson 2007-08-08 00:12:05 EDT
Could test with the Fedora 8 test 1 DVD that was released yesterday.

http://torrent.fedoraproject.org/
Comment 4 Jeff Stern 2007-08-22 13:35:00 EDT
fyi, i used the following install method to get around the "CD Not
Found" error. but this method requires that you have a 2nd (e3fs
formatted) hard disk which you are not installing Fedora to, which you
saved the fedora .iso to first..

in my case, i had a 2nd drive with the /home directories on it. so i
had stored the Fedora 7 .iso in /home/jstern/temp/F-7-i386-DVD.iso and
then run sha1sum on it to make sure it matched the original. then i
rebooted with the F7 DVD in the DVD drive and went through the following
screens:

- install or upgrade an existing system  (either regular or text mode)
- choose a language
- choose a keyboard
- installation method: hard drive (instead of Local CDROM)
- Select partition: /dev/sda2 (or whichever your 2nd or 3rd drive is
  where you have the .iso)
  - Directory holding images: /home/jstern/temp
Comment 5 Jeff Stern 2007-08-22 13:41:23 EDT
sorry, i meant "/dev/sdb2" for the 2nd partition on the 2nd drive.. not
"/dev/sda2" (which would be 2nd partition on 1st drive)
Comment 6 Christopher Brown 2007-09-17 11:51:49 EDT
Hello,

I'm reviewing this bug as part of the kernel bug triage project, an attempt to
isolate current bugs in the fedora kernel.

http://fedoraproject.org/wiki/KernelBugTriage

Is it possible to test with Fedora 8 Test 2 at:

http://fedoraproject.org/wiki/Distribution/Download

as it would help eliminate this from bugzilla suspects leading up to F8.

Cheers
Chris
Comment 7 Jeff Stern 2007-09-17 17:43:30 EDT
christopher i can try but can you supply me with a more specific URL for
download of an f8-t2 dvd iso, just so i'm working with what you want? when i go to

http://fedoraproject.org/wiki/Distribution/Download

all i get is instructions and links for fedora 7 dvd iso's, not 8.

jeff
Comment 8 Christopher Brown 2007-09-17 17:55:14 EDT
Hi Jeff,

Sure, this is a better link:

http://mirrors.fedoraproject.org/publiclist/Fedora/7.91/

and just pick the one closest to you for what is usually the fastest download.

Thanks for doing this.

Chris
Comment 9 Jeff Stern 2007-10-29 16:06:50 EDT
hey, chris, sorry to take so long to get back to you on this. i have downloaded
and burned a DVD for 7.92 from the location you gave me, and i have tested the
install in both my machine at home and my work machine.  however, i only tried
graphical mode (not text mode)..  also, i did not actually try installing.. i
only went so far:

- Fedora splash screen w/release notes (click Next)
- this is beta software (click "Install anyway")
- choose a language during installation process (US English)
- choose a keyboard (US English)
- upgrade an existing installation
- create new bootloader configuration
- the GRUB boot loader will be installed on /dev/sdc (or /dev/sda)
- install Boot loader record on /dev/sdc (/dev/sda) MBR
- checking dependencies...
- "click Next to begin upgrade of Fedora"..

notice i chose the upgrade path, not the "Install a fresh copy" path

when i tried the "install a fresh copy path", it seemed okay, but i could only
go one step farther because it was warning me it would erase all partitions on
this drive, and i didn't want to risk whether or not it would give me one more
screen to okay this, or whether it would go right ahead *now* and do it -- so i
cancelled it and could not go any further in testing for you. however, i did get
at least to that point.

let me know if you need me to do anything else, or if you need any more
information, chris.. --jeff.



i do not seem to have the "CD Not Found" error any more.  
Comment 10 Chuck Ebbert 2007-10-29 16:32:25 EDT
Will also be fixed in the next Fedora 7 respin.

http://spins.fedoraunity.org/spins

Note You need to log in before you can comment on or make changes to this bug.