This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 245696 - Anaconda assumes http install when a Fedora (Everything) repo is enabled.
Anaconda assumes http install when a Fedora (Everything) repo is enabled.
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-06-26 01:28 EDT by Gian Paolo Mureddu
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-23 09:35:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Gian Paolo Mureddu 2007-06-26 01:28:51 EDT
Description of problem:
Anaconda will fetch almost every package off the configured repository instead
of the DVD. Starting the installation process up to the point where the
installation type choice is made, right when extra repositories can be
configured. Setting up extra repositories (like
http://mirrors.kernel.org/fedora/releases/7/Everything/$arch/os) will result in
Anaconda fetching almost all selected packages from the on-line repository
instead of the media disk.

Version-Release number of selected component (if applicable):
anaconda-11.2.0.66


How reproducible:
Frequently

Steps to Reproduce:
1. Start a new installation, configure an "Everything" repository.
2. Select some packages which were on Extras (Inkscape, for instance)
3. Start install process... Anaconda will start fetching some packages from the
repository instead of the disk (like glibc) or the kernel.
  
Actual results:
Anaconda ignores the DVD media, like if the installation was set to be an http
or FTP installation.

Expected results:
For Anaconda to only fetch those packages not present in the local media.

Additional info:
Comment 1 Jeremy Katz 2007-10-04 11:43:38 EDT
Adjusted anaconda to use the yum repo cost bits.  Should be fixed when yum 3.2.6
lands in the tree in the next couple of days.
Comment 2 Rahul Sundaram 2007-10-23 09:35:39 EDT
Closing this since yum 3.2.7 is in rawhide now. 

Note You need to log in before you can comment on or make changes to this bug.