This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 245698 - repomanage: mal-formated error messages
repomanage: mal-formated error messages
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum-utils (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Seth Vidal
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-26 02:03 EDT by Ralf Corsepius
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-26 15:20:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ralf Corsepius 2007-06-26 02:03:48 EDT
Description of problem:

Running repomanage on a repo containing a corrupted rpm, I just received this
mal-formated error message:

# repomanage -o xxx > list
error: rpmts_HdrFromFdno: MD5 digest: BAD
Expected(bef0a124ac09d2a02c739c86f82643dd) != (d7e3fc1564fcd12ef71a10acbe05505d)
('E', 'r', 'r', 'o', 'r', ' ', 'o', 'p', 'e', 'n', 'i', 'n', 'g', ' ', 'p', 'a',
'c', 'k', 'a', 'g', 'e', ' ', 'a', 'l', 'l', '/', 'f', 'e', 'd', 'o', 'r', 'a',
'/', 'F', 'e', 'd', 'o', 'r', 'a', '/', 'g', 'c', 'o', 'm', 'p', 'r', 'i', 's',
'-', 's', 'o', 'u', 'n', 'd', '-', 's', 'v', '-', '8', '.', '2', '.', '2', '-',
'2', '.', 'f', 'c', '7', '.', 'i', '3', '8', '6', '.', 'r', 'p', 'm')


Version-Release number of selected component (if applicable):
yum-utils-1.1.5-1.fc7
yum-3.2.0-1.fc7
Comment 1 Seth Vidal 2007-06-26 15:20:31 EDT
fixed in cvs. You can apply this patch:
https://lists.dulug.duke.edu/pipermail/yum-cvs-commits/2007-June/001786.html

to get it working nicely. The problem was the change in python 2.5's
BaseException class.

Thanks for reporting this.


Note You need to log in before you can comment on or make changes to this bug.