Bug 245700 - git now forces emacs install
git now forces emacs install
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: git (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Chris Wright
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-06-26 02:26 EDT by Nicolas Mailhot
Modified: 2013-01-10 05:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 21:52:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Nicolas Mailhot 2007-06-26 02:26:49 EDT
git now forces emacs install - that's over the top

Updating:
 git                     x86_64     1.5.2.2-2.fc8    koji-f8-builds    5.9 k
 git-arch                x86_64     1.5.2.2-2.fc8    koji-f8-builds     25 k
 git-core                x86_64     1.5.2.2-2.fc8    koji-f8-builds    4.3 M
 git-cvs                 x86_64     1.5.2.2-2.fc8    koji-f8-builds     61 k
 git-email               x86_64     1.5.2.2-2.fc8    koji-f8-builds     19 k
 git-gui                 x86_64     1.5.2.2-2.fc8    koji-f8-builds     49 k
 git-svn                 x86_64     1.5.2.2-2.fc8    koji-f8-builds     73 k
 gitk                    x86_64     1.5.2.2-2.fc8    koji-f8-builds     55 k
 perl-Git                x86_64     1.5.2.2-2.fc8    koji-f8-builds     15 k
Installing for dependencies:
 emacs-common            x86_64     22.0.990-2.fc7   fedora-devel       18 M
 emacs-git               x86_64     1.5.2.2-2.fc8    koji-f8-builds     42 k
Comment 1 Josh Boyer 2007-06-26 07:15:57 EDT
Only if you use the git meta package, which is intended to bring in everything.
 If you just want git, use git-core.
Comment 2 Josh Boyer 2007-06-27 21:52:05 EDT
Marking as not a bug.  git is a meta-package and the individual packages can be
installed if users don't want to install everything.
Comment 3 David Fraser 2008-04-10 05:55:45 EDT
(In reply to comment #2)
> Marking as not a bug.  git is a meta-package and the individual packages can be
> installed if users don't want to install everything.

Note that in bug 433209, git (the meta-package) was renamed to git-all, and
git-core was renamed to git. This means that other packages that naively depend
on git won't pull in all the unnecessary dependencies

Note You need to log in before you can comment on or make changes to this bug.