Bug 245717 - problem in udev regarding LUKS identification
problem in udev regarding LUKS identification
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: udev (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Harald Hoyer
Fedora Extras Quality Assurance
http://article.gmane.org/gmane.comp.f...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-26 05:49 EDT by Karsten Hopp
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-07 09:15:12 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Karsten Hopp 2007-06-26 05:49:04 EDT
Description of problem:
udev sets its magic string in the first 512 bytes
of the partition.  This is dangerous and error-prone, because other
things like boot sectors and BSD disk labels tend to live in the first
512 byte sector.

Additional info:
Please report to upstream, full text available at
http://article.gmane.org/gmane.comp.file-systems.ext4/2316/
Comment 1 Harald Hoyer 2007-06-26 09:53:38 EDT
"udev sets its magic string in the first 512 bytes"

s/sets/gets/
 
Comment 2 Kay Sievers 2007-06-27 12:58:43 EDT
That's nothing new. Guessing filesystems by magic bytes on the disk is by
definition unsafe.

_All_ filesystem formatters are required to wipe out _all_ existing signatures
before applying a new signature. Even then, it's not entirely safe to probe, but
we obviously have no alternatives.

Shuffling the probing order around will only switch the systems where such
problems occur. From my standpoint, you can close this "bug". Thanks!
Comment 3 Karsten Hopp 2007-08-07 09:15:12 EDT
Closing based on comment #2. All formatters need to wipe out all signatures

Note You need to log in before you can comment on or make changes to this bug.