Bug 245741 - Unable to get more than 800x600 screen resolution with new FC6 kernel
Unable to get more than 800x600 screen resolution with new FC6 kernel
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-26 09:02 EDT by Mike Cohler
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-27 16:39:25 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
xorg log with new kernel (57.22 KB, application/octet-stream)
2007-06-26 09:03 EDT, Mike Cohler
no flags Details
xorg log with new kernel - text file (57.22 KB, text/plain)
2007-06-26 09:04 EDT, Mike Cohler
no flags Details
xorg log with old kernel - text file (60.16 KB, text/plain)
2007-06-26 09:05 EDT, Mike Cohler
no flags Details
/var/log/messages (122.77 KB, text/plain)
2007-06-26 09:11 EDT, Mike Cohler
no flags Details
xorg.conf as autogenerated by the system (566 bytes, text/plain)
2007-06-27 06:04 EDT, Mike Cohler
no flags Details

  None (edit)
Description Mike Cohler 2007-06-26 09:02:59 EDT
Description of problem:Ran yum update and booted to new kernel
kernel-2.6.20-1.2962.fc6.  Unable to get better than 800x600, but rebooting back
to previous kernel without further change returns the screen to normal resolution.


Version-Release number of selected component (if
applicable):kernel-2.6.20-1.2962.fc6 and xorg-x11-server-Xvfb.i386 1.1.1-47.10.fc6


How reproducible:Every time


Steps to Reproduce:
1. Yum update
2. Re-boot
3. Monitor resolution is 800x600 and no better resolution is possible even if
change attempted with system-config-display
  
Actual results:Resolution unable to get to previously set value. If machine is
rebooted back to kernel-2.6.20-1.2952.fc6 then screen resolution returns to normal.


Expected results: Machine should display normal resolution with new kernel


Additional info:Running KDE, and hardware profile is at 
http://smolt.fedoraproject.org/show?UUID=bd6fa448-485f-4640-b89b-b83c8d8111d3

xorg logs attached.
Comment 1 Mike Cohler 2007-06-26 09:03:00 EDT
Created attachment 157891 [details]
xorg log with new kernel
Comment 2 Mike Cohler 2007-06-26 09:04:03 EDT
Created attachment 157892 [details]
xorg log with new kernel - text file
Comment 3 Mike Cohler 2007-06-26 09:05:10 EDT
Created attachment 157893 [details]
xorg log with old kernel - text file
Comment 4 Mike Cohler 2007-06-26 09:11:04 EDT
Created attachment 157894 [details]
/var/log/messages
Comment 5 Chuck Ebbert 2007-06-26 17:07:30 EDT
This is probably the cause:

-(II) I810(0): VESA VBE DDC read successfully
+(II) I810(0): VESA VBE DDC read failed

But why it would suddenly stop working, I don't understand.
There aren't any kernel patches in there that should have caused this...
You should be able to work around this by adding

   HorizSync 31-80
   VertRefresh 56-75

to the "monitor" section of /etc/X11/xorg.conf.

Comment 6 Mike Cohler 2007-06-27 06:04:48 EDT
Created attachment 157988 [details]
xorg.conf as autogenerated by the system
Comment 7 Mike Cohler 2007-06-27 06:06:45 EDT
There was no monitor section in xorg.conf - the xorg.conf file was
autogenerated. I have attached the original file at #6. After appending a
section containing:

Section "Monitor"
        Identifier   "Monitor0"
        VendorName   "Monitor Vendor"
        ModelName    "Monitor Model"
        HorizSync    31-80
        VertRefresh  56-75
EndSection

I restarted X with the original kernel running, and this now produced the same
problem with no more than 800x600 resolution that I get with the new kernel!
Maybe the xorg.conf file needs to have other changes?
Comment 8 Chuck Ebbert 2007-06-27 16:53:15 EDT
I'm not an Xpert but I think it needs to have

     Monitor "Monitor0"

added to the Screen section?

Comment 9 Chuck Ebbert 2007-06-27 16:56:33 EDT
Can we get a copy of boot messages from the old kernel?
Comment 10 Mike Cohler 2007-06-28 03:57:59 EDT
Thanks Chuck - I am away from the machine at meetings all today but I will check
the xorg.conf details tomorrow and test - and will attach copies of
/var/log/messages with relevant lines tomorrow when I am back at the machine.
There is no boot.log
Comment 11 Mike Cohler 2007-07-02 08:03:53 EDT
I added the Monitor line to xorg.conf, and the machine does boot and gives X
with the required resolution. However the normal boot progress screen is blank
apart from a message (presumably from the monitor itself) saying that the
optimum resolution is 1280x1024 which is what it should choose anyway! Clearly
it does not choose the correct resolution until X itself starts.

I will soon be installing F7 on this machine and although this seems to be a
workaround I am not sure this bug is fully resolved.

I hope that once F7 is installed and updated that this problem will not recur on
this machine.
Comment 12 Mike Cohler 2007-07-02 12:23:25 EDT
I have done a clean f7 install on this machine, and am fully yum updated running
kernel 2.6.21-1.3228.fc7 - the problem reported in this bug does not occur with
f7 on either the original kernel or the current one.

If no-one else reports further after this then I guess this bug should be closed?
Comment 13 Adam Jackson 2007-07-27 16:39:25 EDT
There was at least one bug in ~FC6 where the kernel's vm86 call would clobber
some registers before returning to userspace, which would confuse X horribly and
usually manifest as DDC failing.

The offending code appears to be gone in F7, so, hooray.

Note You need to log in before you can comment on or make changes to this bug.