Bug 245755 - Pirut misses dependencies
Pirut misses dependencies
Status: CLOSED DUPLICATE of bug 242368
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
7
All Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-26 10:21 EDT by Florian Festi
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-26 18:30:08 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Festi 2007-06-26 10:21:03 EDT
Under not very unlikely conditions pirut installs packages with broken
dependencies. 

Version-Release number of selected component (if applicable):
pirut-1.3.7-1.fc7

How reproducible:
always

Steps to Reproduce:
1.select packages that require additional packages
2.press apply
3.press cancel when presented the additional requirements
4.press apply again and install previously selecte packages

Actual results:
requirements are NOT installed

Expected results:
ask about the requirements again and install them

Additional info:
There are several other scenarios where this problem can show up.

Reason for this is a bug in yum that is currently only triggered by pirut.
Depsolver.deps is a cache saving matching provides for requirements. This cache
is never invalidated. As pirut reuses (in fact cosists of) the Depsolver results
from earlier queries get into the resolving although they are no longer part of
the current transaction.
Comment 1 Jeremy Katz 2007-06-26 18:30:08 EDT

*** This bug has been marked as a duplicate of 242368 ***

Note You need to log in before you can comment on or make changes to this bug.