Bug 245764 - "restore saved session" setting lost with 3.5.7 update
"restore saved session" setting lost with 3.5.7 update
Status: CLOSED DUPLICATE of bug 242564
Product: Fedora
Classification: Fedora
Component: kde-settings (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-26 11:12 EDT by Orion Poplawski
Modified: 2007-11-30 17:12 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-03 05:50:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Orion Poplawski 2007-06-26 11:12:47 EDT
Description of problem:

Updated to 3.5.7-0.1 and my previous setting of restoring a saved session was
lost and instead it restored the session as it was on logout.

Version-Release number of selected component (if applicable):
kdebase-3.5.7-0.1.fc7

How reproducible:
haven't tried.
Comment 1 Rex Dieter 2007-06-26 11:24:12 EDT
Yes, the default was changed in upgrade
kde-setting-3.5-29 -> kde-settings-3.5-29
"Restore manually saved session" 
to
"Restore previous session"

See bug #242564 for background.
Comment 2 Orion Poplawski 2007-06-26 11:37:52 EDT
Hm, so I guess when I went from FC6 -> F7 it no longer saved my loginMode in
ksmserverrc because it was now the default?  Then when the default changed I got
the new default?  If so, what a pain.  You might make note of it in the update
announcement.

I'm surprised the setting went away though as it was something I had to
explicitly set way back whenever it was that I first set it (RH9?).
Comment 3 Rex Dieter 2007-07-03 05:50:00 EDT

*** This bug has been marked as a duplicate of 242564 ***
Comment 4 Kevin Kofler 2007-07-03 10:24:13 EDT
Yes, this was changed somehow accidentally with the introduction of kde-setting 
(e.g. in the kde-settings-3.5-28.fc7.1 which shipped in F7). (It was one of the 
places where the kde-redhat setting and the setting in the official Fedora 
packages were different. There was no time left before the F7 release to look 
at all the differences and discuss them, so some unwanted changes slipped in. 
See bug 242564 for details.) kde-settings-3.5-29.fc7 restores the original Red 
Hat / Fedora default, your problem is an unfortunate side effect.

Note You need to log in before you can comment on or make changes to this bug.