Bug 245770 - Misplaced mysql_config script
Misplaced mysql_config script
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: mysql (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Tom Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-26 12:20 EDT by Carlos Daniel Ruvalcaba Valenzuela
Modified: 2013-07-02 23:13 EDT (History)
1 user (show)

See Also:
Fixed In Version: 5.0.45-1.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-25 04:28:01 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Carlos Daniel Ruvalcaba Valenzuela 2007-06-26 12:20:44 EDT
Description of problem:
MySQL server package includes the file mysql_config which is used to determine
configuration flags for compiling programs using mysql.

Version-Release number of selected component (if applicable):
mysql-5.0.37-2.fc7

How reproducible:
Always

Steps to Reproduce:
1. Install MySQL server package (mysql-5.0.37-2.fc7) and mysql-libs package
without installing mysql-devel.
2. Compile a software that uses mysql, the program must not use autotools, for
example MySQL-Python or custom scripts that depend on mysql_config for detecting
mysql installation.
  
Actual results:
The compilation will start as if the mysql libraries and development files where
detected correctly, the compilation will fail because of missing mysql.h and
related headers.

Expected results:
Compilation should not even start, if mysql-devel is not installed mysql_config
should not be installed, compilation scripts should then detect correctly that
mysql-devel is missing, this is the behavior expected from *-config scripts (for
example pg_config).

Additional info:
Autoconf probably works around this by compiling a test program.
Comment 1 Tom Lane 2007-06-26 13:09:10 EDT
The reason mysql_config is in the base package is that it has other uses besides compilation, for example 
detecting which port to use for mysql and where the socket file is.  Moving it to mysql-devel would break 
packages that depend on it for those purposes.  Possibly it's an upstream design error to have used 
mysql_config for both compile-time and run-time purposes, but we're stuck with it now.

I do see a packaging bug here, which is that its man page is in the -server subpackage; apparently a 
thinko on my part when they added a man page for it in 5.0.16.  Should be in base.
Comment 2 Tom Lane 2007-07-22 19:51:08 EDT
Moved the man page as of mysql-5.0.45-1
Comment 3 Fedora Update System 2007-07-23 11:44:47 EDT
mysql-5.0.45-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 4 Fedora Update System 2007-09-25 04:27:57 EDT
mysql-5.0.45-1.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.