Bug 245778 - cannot write to a usb stick
Summary: cannot write to a usb stick
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-volume-manager   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: David Zeuthen
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
: 245771 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-26 17:35 UTC by Cameron Meadors
Modified: 2013-03-06 03:51 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 14:32:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Cameron Meadors 2007-06-26 17:35:22 UTC
Description of problem:

When I insert a Lexar JumpDrive, it is mounted, but I cannot write to it as the
logged in user.  Root is able to write to it.  I appears that the ownership is
not set correctly when mounted.  I have other usb media that works fine (I can
write to them).

Version-Release number of selected component (if applicable):

gnome-volume-manager-2.17.0-7.fc7

How reproducible:

Everytime with this one usb device.

Steps to Reproduce:
1.  Plug in the use stick
2.  Try to create a file on the device.
3.
  
Actual results:

Permission denied error

Expected results:

File is created

Additional info:

Comment 1 Matthias Clasen 2007-06-27 03:57:25 UTC
*** Bug 245771 has been marked as a duplicate of this bug. ***

Comment 2 Cameron Meadors 2007-06-27 14:32:48 UTC
This turns out to be user error completely.  The files on the usb stick were not
owned by me.  I was expecting to have ownership squashed with mount options as
happens when the filesystem in vfat.  This one however was ext2.  I guess this
just highlights the need for better user (non-root) tools for removable media.


Note You need to log in before you can comment on or make changes to this bug.