Bug 245816 - FEAT: RHEL5.1: upgrade openib, openmpi to OFED 1.2
FEAT: RHEL5.1: upgrade openib, openmpi to OFED 1.2
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: openib (Show other bugs)
5.0
All Linux
high Severity medium
: ---
: ---
Assigned To: Doug Ledford
: FutureFeature
Depends On: 225581
Blocks: 245817
  Show dependency treegraph
 
Reported: 2007-06-26 16:32 EDT by Doug Ledford
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version: RHEA-2007-0645
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 12:01:49 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Ledford 2007-06-26 16:32:24 EDT
+++ This bug was initially created as a clone of Bug #225581 +++

1. Feature Name:  upgrade openib, openmpi to OFED 1.2


2. Description:
   a. Architectures (mark all that apply)
        32-bit x86
      * 64-bit Itanium2
      * 64-bit AMD64/Intel EM64T
        64-bit IBM POWER
        31-bit IBM S/390
        64-bit IBM zSeries

   b. Dependencies:  OFED 1.2 release from community in April/May 2007

   c. External links:  www.openfabrics.org

   d. Priority (H,M,L): H

   e. Target Releases:  RHEL 5.1 

   f. Target Release Date:

   g. Drivers or hardware dependency:  InfiniBand 

   h. Target Kernel:
  
3. Business Justification:   
   a. Why is this feature needed?  
        Distro support for IB native will mean it is well integrated with the
        rest of the distro. HPC IB cluster sales have been growing.

   b. What hardware does this enable?  InfiniBand

   c. Forecast, volume or high end platform?  Carlsbad is a high-end platform

   d. Any configuration info?  

   e. When needed?  RHEL5.1 or sooner

   f. Are there other dependencies (drivers).

4. Status:
   a. Is code accepted upstream? If so, what version or patch?  
        Yes the kernel code is in 2.6.11 onwards, but they need to pick
        a more recent version based on OFED 1.2 release.
    

        There are changes in 2.6.20 which could be worth taking
        (just use the OFED 1.2 release)

5. Hardware to Red Hat? Red Hat can't integrate/test features without hardware.
   Gallup (BZ#223419) and Carlsbad (BZ# 223545) products are scheduled
   to come to Westford.

6. Partner management contact, email, phone, chat

   John Hesterberg, jh@sgi.com, 651-683-5879, N/A

7. Partner technical contact, email, phone, chat

   George Beshers, gbeshers@sgi.com, 978-392-2447, N/A

   Where/location:  Westford, MA

-- Additional comment from dledford@redhat.com on 2007-01-31 10:29 EST --
In Westford, Gurhan Ozen <gozen@redhat.com> is the QE engineer assigned to IB
testing.  Please make sure that any hardware intended for IB testing is properly
labeled and Gurhan notified so that it can be used in our QE IB fabric.  If
there are special development needs on these platforms, I'll coordinate with
Gurhan to make sure it is covered.

-- Additional comment from rpacheco@redhat.com on 2007-02-19 11:24 EST --
Doug,

Can you update us on this?  Will this make 5.1?

-- Additional comment from dledford@redhat.com on 2007-02-19 12:38 EST --
Not yet.  The upstream 1.2 OFED release is only in alpha testing right now. 
Whether or not it makes 5.1 is dependent on when they actually have a 1.2 release.

-- Additional comment from martinez@redhat.com on 2007-05-02 14:35 EST --
Groupe Bull is also asking for this.

-- Additional comment from martinez@redhat.com on 2007-05-02 15:03 EST --
Hey Doug -- Could you give us a quick update on the current status of upstream
1.2 OFED? Thanks!

-- Additional comment from riek@redhat.com on 2007-05-26 05:28 EST --
Approved component for 5.1 PM ACK

-- Additional comment from rbiba@redhat.com on 2007-05-31 12:49 EST --
QA ACK for 5.1.0. Looks like we have an assigned QA guy already (comment 1).

-- Additional comment from martinez@redhat.com on 2007-06-01 16:52 EST --
Red Hat Product Management and Engineering have evaluated this request and
currently plan to include it in the next Red Hat Enterprise Linux minor release.
Please note that its inclusion depends upon the successful completion of code
integration and testing.
Comment 1 Doug Ledford 2007-06-26 16:33:45 EDT
I have to clone the original bug because I need separate bugs for each component
involved or else our system won't let me A) check in changes to CVS and B) file
the errata.
Comment 7 errata-xmlrpc 2007-11-07 12:01:49 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHEA-2007-0645.html

Note You need to log in before you can comment on or make changes to this bug.