Bug 245822 - ppc /usr/include/asm/types.h is broken
ppc /usr/include/asm/types.h is broken
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.0
All Linux
urgent Severity high
: ---
: ---
Assigned To: Red Hat Kernel Manager
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-26 16:48 EDT by Steve Grubb
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 05:44:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2007-06-26 16:48:25 EDT
Description of problem:
When building the audit package for the RHEL5.1 release, swig dies like this:

make[2]: Entering directory `/builddir/build/BUILD/audit-1.5.4/swig'
swig -o audit_wrap.c -python -I. -I.. -I../lib -I/usr/include/python2.4
./auditswig.i 
/usr/include/asm/types.h:51: Error: Syntax error in input(3).

Version-Release number of selected component (if applicable):
kernel-headers-2.6.18-29.el5.ppc

How reproducible:
every time

Steps to Reproduce:
1. make build
2. watch brew

  
Actual results:
ppc fails, other arches do not.

Expected results:
audit to build like other arches do.

Additional info:
This is blocking the audit errata completion for RHEL5.1.
Comment 2 Miloslav Trmač 2007-06-27 05:44:26 EDT
This was caused by swig, which can't parse __attribute(...).

Note You need to log in before you can comment on or make changes to this bug.