Bug 245825 - xsane does not scan with Canon LiDE25
xsane does not scan with Canon LiDE25
Status: CLOSED DUPLICATE of bug 243953
Product: Fedora
Classification: Fedora
Component: xsane (Show other bugs)
7
x86_64 Linux
low Severity medium
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-26 17:12 EDT by Marcel Kyas
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-17 09:23:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Marcel Kyas 2007-06-26 17:12:30 EDT
Description of problem:

I cannot scan using xsane.  Trying to scan a preview will always result in a
black screen after some time waiting without scanner activity.

Version-Release number of selected component (if applicable):

xsane-0.994-3.fc7

How reproducible:

Always.

Steps to Reproduce:
1. Start xsane
2. Click Aquire preview
3. 
  
Actual results:

No activity of the scanner and a black image in the preview window.


Expected results:

A preview scan


Additional info:

scanimage -L reports

device `plustek:libusb:001:004' is a Canon LiDE25 USB flatbed scanner

scanimage -T reports

scanimage: scanning image of size 202x150 pixels at 24 bits/pixel
scanimage: acquiring RGB frame, 8 bits/sample
scanimage: reading one scanline, 606 bytes...   PASS
scanimage: reading one byte...          PASS
scanimage: stepped read, 2 bytes...     PASS
scanimage: stepped read, 4 bytes...     PASS
scanimage: stepped read, 8 bytes...     PASS
scanimage: stepped read, 16 bytes...    PASS
scanimage: stepped read, 32 bytes...    PASS
scanimage: stepped read, 64 bytes...    PASS
scanimage: stepped read, 128 bytes...   PASS
scanimage: stepped read, 256 bytes...   PASS
scanimage: stepped read, 512 bytes...   PASS
scanimage: stepped read, 1024 bytes...  PASS
scanimage: stepped read, 1023 bytes...  PASS
scanimage: stepped read, 511 bytes...   PASS
scanimage: stepped read, 255 bytes...   PASS
scanimage: stepped read, 127 bytes...   PASS
scanimage: stepped read, 63 bytes...    PASS
scanimage: stepped read, 31 bytes...    PASS
scanimage: stepped read, 15 bytes...    PASS
scanimage: stepped read, 7 bytes...     PASS
scanimage: stepped read, 3 bytes...     PASS


I can scan from the command line using scanimage without any problems.
Comment 1 Luis 2007-07-11 11:12:47 EDT
I have the same problems with an Epson perfection 660. Previously it worked ok,

While trying to adquire preview or to scan, in the console it appears the message 

[snapscan] Scanner warming up - waiting 31 seconds.

Again and again. Using scanimage, this message only appears once or twice and
then it scans correctly.
Comment 2 Máirín Duffy 2007-07-11 15:05:56 EDT
Same problem with the LiDE 30, which has worked flawlessly from FC4 to FC6 and
in RHEL 4 and RHEL 5.
Comment 3 Nils Philippsen 2007-07-12 02:43:53 EDT
All, has it worked with the xsane-0.994 update in FC-6?
Comment 4 Edward Weening 2007-07-16 09:22:28 EDT
I had the same problem with the LiDE20. Everything worked fine in FC-6 but not
in F7.
After reading about similar problems on the Dutch Ubuntu site
(http://forum.ubuntu-nl.org/message/120471), I installed scanbuttond:

yum install scanbuttond
service scanbuttond start

Result: all problems are gone!

Comment 5 Marcel Kyas 2007-07-16 10:19:21 EDT
I remember that my scanner worked in FC-6, but I do not remember whether the
last version I used in FC6 has been 0.994.

The symptoms are indeed identical to this ubuntu bug: 
https://bugs.launchpad.net/ubuntu/+source/sane-backends/+bug/85488 .  Installing
and starting scanbuttond works around this problem.

Still scanimage can scan and xsane cannot, which indicates that there is a bug
in xsane.
Comment 6 Thomas Canniot 2007-07-16 11:43:21 EDT
> All, has it worked with the xsane-0.994 update in FC-6?

It does still work with the xsane-0.994-2.fc6 package on FC-6. It does not with
the latest xsane package on FC-7.
Comment 7 Nils Philippsen 2007-07-16 12:18:47 EDT
All, I suspect that this is a duplicate of bug 243953.

Please try whether _one_ of the following fixes the problem:

a) with a current F7 kernel, add "usbcore.autosuspend=0" without the quotes to
the kernel command line, reboot

b) install kernel version 2.6.21-1.3255.fc7 from updates-testing and reboot into
that

Thanks.
Comment 8 Edward Weening 2007-07-17 07:11:52 EDT
I can confirm that fix a) add "usbcore.autosuspend=0" to the kernel command line
solves my problems, without installing scanbuttond.

I use kernel version 2.6.21-1.3228.fc7
Comment 9 Nils Philippsen 2007-07-17 09:23:49 EDT

*** This bug has been marked as a duplicate of 243953 ***

Note You need to log in before you can comment on or make changes to this bug.