Bug 245855 - Gnome Applet Invest: can't add stocks
Summary: Gnome Applet Invest: can't add stocks
Status: CLOSED UPSTREAM
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-applets   
(Show other bugs)
Version: 7
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Ray Strode [halfline]
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-27 00:26 UTC by jaymz
Modified: 2007-11-30 22:12 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-04 21:28:25 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Bugzilla 473706 None None None Never

Description jaymz 2007-06-27 00:26:42 UTC
Description of problem:
when i click "+add" in the invest applet preferences, it just adds google over
and over again

Version-Release number of selected component (if applicable):
gnome-applets-2.18.0-7.fc7

How reproducible:
always

Steps to Reproduce:
1. click add


  
Actual results:
adds google

Expected results:
pop up dialog box to input different stock that i actually want to track

Additional info:
.. did wiki/forum/buzilla search for this, couldn't find an answer

.. went to help page for application, doesn't seem to exist anymore:
http://raphael.slinckx.net/invest

.. edited the .gnome2/invest-applet/stocks.pickle file manually and i can get my
stock in there and the applet updates correctly, but i cannot figure out the
format to add in multiple stocks.

Comment 1 Peter H. Jones 2007-09-01 12:42:49 UTC
Still seeing this bug in fc8test1, would like to reopen, but am not authorize to
change version or bug status. I have gnome-applets-2.19.1-8.fc8 .

Comment 2 Ray Strode [halfline] 2007-09-04 14:18:32 UTC
Hi Peter,

If you click on the "GOOG" text, and type in a new ticker symbol does it work as
expected?

Comment 3 Peter H. Jones 2007-09-04 15:32:11 UTC
I can make the symbol GOOG appear by clicking on the button.

If I single-click the symbol test, with either mouse button, nothing happens; I
don't get a window to type in text.

If I double-click on the text, I  get charts, and I can change the symbol. But
after closing the chart, the symbol remains at GOOG; I don't seem to be able to
add a new symbol on a permanent basis.


Comment 4 Ray Strode [halfline] 2007-09-04 16:16:16 UTC
Oh, I'm sorry, I wasn't very clear. 

next to ticker icon is an arrow.  next to the arrow is a blank box.  If you
right click on the blank box, a context menu will come up.  From there you can
go to preferences, and a dialog will pop up with the GOOG entry.  If you click
the GOOG text there, it should become editable.

Does that work?  It's pretty complicated, I agree.  If that works, we should
file an upstream bug to see if we can get a clearer interface.

Comment 5 Peter H. Jones 2007-09-04 16:51:04 UTC
I don't see an arrow, just a button next to the purple chart icon. When I click
on the button, I get a blue box containing the text: "GOOG: +521 (+6.66%)". This
value can fluctuate, of course. I have also found I can click and drag this box,
but it returns to its initial position when I release it.

Kudos for the multi-year charts.


Comment 6 Ray Strode [halfline] 2007-09-04 17:07:39 UTC
right-click in the blank area to the right of the button.

That is, if you hold your mouse over the chart, you should see the entire thing
turn into a sort of button,  move your mouse to the right until it no longer
looks like a button, then right click, and go to preferences from there.

Comment 7 Peter H. Jones 2007-09-04 21:04:19 UTC
It does work that way, provided I enter existing stock symbols in UPPER CASE.

Comment 8 Ray Strode [halfline] 2007-09-04 21:28:25 UTC
I've filed an upstream bug here:

http://bugzilla.gnome.org/show_bug.cgi?id=473706

to cover the UI improvements.


Note You need to log in before you can comment on or make changes to this bug.