Bug 245931 - parallel make bug
parallel make bug
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: emacs (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Chip Coldwell
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-27 10:15 EDT by Chip Coldwell
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-10 14:29:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Chip Coldwell 2007-06-27 10:15:50 EDT
Description of problem:

parallel make problem: occassionally

+ /usr/bin/make -j8 -C lisp updates
make: Entering directory `/builddir/build/BUILD/emacs-22.1/lisp'
[ ... ]
Directory /builddir/build/BUILD/emacs-22.1/lisp/.
Generating autoloads for subdirs.el...
Generating autoloads for subdirs.el...done
Generating autoloads for eshell/esh-groups.el...
Generating autoloads for eshell/esh-groups.el...done
Saving file /builddir/build/BUILD/emacs-22.1/lisp/loaddefs.el...
Opening input file: no such file or directory,
/builddir/build/BUILD/emacs-22.1/lisp/loaddefs.el
make: *** [finder-data] Error 255
make: *** Waiting for unfinished jobs....
Wrote /builddir/build/BUILD/emacs-22.1/lisp/loaddefs.el

seems to be some sort of a race in building/using loaddefs.el

Version-Release number of selected component (if applicable):

22.1-1

How reproducible:

usually

Note You need to log in before you can comment on or make changes to this bug.