Bug 245932 - Suspend on Lenovo X60s broken
Suspend on Lenovo X60s broken
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: hal (Show other bugs)
5.0
All Linux
low Severity low
: ---
: ---
Assigned To: David Zeuthen
:
Depends On:
Blocks: 418031
  Show dependency treegraph
 
Reported: 2007-06-27 10:16 EDT by Florian Festi
Modified: 2013-03-05 22:51 EST (History)
3 users (show)

See Also:
Fixed In Version: 0.5.8.1-23.el5
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-24 05:30:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Florian Festi 2007-06-27 10:16:10 EDT
Version-Release number of selected component (if applicable):
hal-0.5.8.1-21.el5 not yet released update package

(pm-utils updated to 0.99.3-6.el5.8)
 
How reproducible:
always

Steps to Reproduce:
1. pm-suspend
2. computer suspends
3. press power button
4. computer does something but is not restored, display stays off.

Additional info:
Suspend works if invoked as 

pm-suspend --quirk-vbe-post --quirk-dpms-suspend

which are the quirks that where used in GOLD by the per video card autodetection.

hal-device shows that hal thinks s3_mode and s3_bios should be used. 
system.hardware.product is "17044DG"
Comment 1 David Zeuthen 2007-06-27 11:32:20 EDT
As explained in bug 236907 comment 2 these quirks are for Fedora 7 and RHEL5
requires other quirks because the kernel and X drivers are different. What video
card and video driver are you using?
Comment 2 Richard Hughes 2007-06-27 11:55:45 EDT
Yes, the vbe post is semi-expected as we are using the i810 not the intel
driver. Does the resume also work with:

pm-suspend --quirk-vbe-post --quirk-s3-mode --quirk-s3-bios

Thanks.
Comment 3 Florian Festi 2007-06-27 12:08:26 EDT
pm-suspend --quirk-vbe-post --quirk-s3-mode --quirk-s3-bios
works

Graphics driver is "i810" as this is a plain RHEL5. 

lspci -n reports  00:02.0 0300: 8086:27a2 (rev03) 
Comment 4 Richard Hughes 2007-06-27 12:12:36 EDT
Okay, I'm guessing we'll need to add vbe-post to the majority of the
intel-graphics lenovo laptops we have in the quirk database.
Comment 5 Florian La Roche 2007-07-24 03:28:01 EDT
Florian Festi, does this work now with current 5.1 beta?

regards,

Florian La Roche
Comment 6 Florian Festi 2007-07-24 05:02:17 EDT
Works for me with 
kernel-2.6.18-36.el5
pm-utils-0.99.3-6.el5.11

Note You need to log in before you can comment on or make changes to this bug.