Bug 245956 - rhn_register crashes "up2date_client.rhnreg.InvalidDefaultError"
rhn_register crashes "up2date_client.rhnreg.InvalidDefaultError"
Status: CLOSED DUPLICATE of bug 229785
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Configuration Management (Show other bugs)
unspecified
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Mike McCune
Red Hat Satellite QA List
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-27 12:17 EDT by Steven Kroon
Modified: 2007-10-23 22:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 13:42:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steven Kroon 2007-06-27 12:17:04 EDT
Description of problem:

Running rhn_register works until i've filled in my *correct* username/password 
combination. If i fill in incorrect credentials i get a nice error message 
telling my that my username/password is incorrect.

--------------------------------------------------------
[root@redhat5 /]# rhn_register
An error has occurred:
up2date_client.rhnreg.InvalidDefaultError
See /var/log/up2date for more information
[root@redhat5 /]# cat /var/log/up2date
[Wed Jun 27 17:48:57 2007] rhn_register
Traceback (most recent call last):
  File "/usr/sbin/rhn_register", line 79, in ?
    app.run()
  File "/usr/share/rhn/up2date_client/rhncli.py", line 65, in run
    sys.exit(self.main() or 0)
  File "/usr/sbin/rhn_register", line 64, in main
    ui.main()
  File "/usr/share/rhn/up2date_client/tui.py", line 1834, in main
    tui.run()
  File "/usr/share/rhn/up2date_client/tui.py", line 1745, in run
    result = win.run()
  File "/usr/share/rhn/up2date_client/tui.py", line 469, in run
    self.passwordEntry.value())
  File "/usr/share/rhn/up2date_client/tui.py", line 66, in tui_call_wrapper
    results = func(*params)
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 807, in getPossibleOrgs
    cachedOrgs.setDefaultOrg(orgsFromServer['default_org'])
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 764, in setDefaultOrg
    raise InvalidDefaultError("Tried to set default org to %s. Valid "
up2date_client.rhnreg.InvalidDefaultError: Tried to set default org to 5453675. 
Valid values are []

[root@redhat5 /]#
--------------------------------------------------------

When running "rhnreg_ks" though it works, so i managed to register my machine 
via this way. However i find it strange that it doesn't work 
with "rhn_register".
Comment 1 Pradeep Kilambi 2007-06-27 13:42:55 EDT
this was fixed in 5.1 as a part of bz#229785

*** This bug has been marked as a duplicate of 229785 ***

Note You need to log in before you can comment on or make changes to this bug.