Bug 245959 - missing ownership on /usr/include/python2.5
Summary: missing ownership on /usr/include/python2.5
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: python-numeric   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
low
low
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords: Reopened
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2007-06-27 16:27 UTC by Ralf Corsepius
Modified: 2008-05-21 11:05 UTC (History)
1 user (show)

Fixed In Version: 24.2-11.fc9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-21 11:05:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ralf Corsepius 2007-06-27 16:27:55 UTC
Description of problem:
python-numeric must own /usr/include/python2.5, because it does not depend on
another package owning it.

Version-Release number of selected component (if applicable):
python-numeric-24.2-4.fc7

Steps to Reproduce:
1. yum install python-numeric
2. Deinstall any package owning /usr/include/python2.5
(According to repoquery the only one besides python-numeric is python-devel)

Actual results:
# rpm -qf /usr/include/python2.5
file /usr/include/python2.5 is not owned by any package

Additional info:
This bug causes orphaned/unowned /usr/include/python* directories to stay on
systems upon upgrades.

Comment 1 Matthew Barnes 2007-07-14 22:18:58 UTC
Fixed in python-numeric-24.2-5.fc7 and python-numeric-24.2-5.fc8.

Comment 2 petrosyan 2008-04-12 01:24:52 UTC
this bug reappeared in python-numeric-24.2-10.fc9

$ rpm -qf /usr/include/python2.5
file /usr/include/python2.5 is not owned by any package

$ rpm -qf /usr/include/python2.5/*
python-numeric-24.2-10.fc9.x86_64

Comment 3 Matthew Barnes 2008-04-12 02:03:55 UTC
Fixed again in python-numeric-24.2-11.fc9.

Will be pushed to Updates after Fedora 9 release.

Comment 4 Fedora Update System 2008-05-07 16:39:56 UTC
python-numeric-24.2-11.fc9 has been submitted as an update for Fedora 9

Comment 5 Fedora Update System 2008-05-21 11:05:28 UTC
python-numeric-24.2-11.fc9 has been pushed to the Fedora 9 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.