Bug 245965 - Latest intel driver broke VGA output.
Latest intel driver broke VGA output.
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-i810 (Show other bugs)
All Linux
low Severity medium
: ---
: ---
Assigned To: Adam Jackson
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-06-27 13:39 EDT by Peter Robinson
Modified: 2008-03-26 06:25 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-03-26 06:25:03 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)
xorg.log from xorg.conf (64.88 KB, text/plain)
2007-07-03 04:46 EDT, Peter Robinson
no flags Details
xorg.conf (1.44 KB, application/octet-stream)
2007-07-03 04:47 EDT, Peter Robinson
no flags Details
xorg.log from autodetect (69.03 KB, text/plain)
2007-07-03 04:49 EDT, Peter Robinson
no flags Details
laptop display no dock auto detect log (54.72 KB, text/plain)
2007-07-11 16:36 EDT, Peter Robinson
no flags Details

  None (edit)
Description Peter Robinson 2007-06-27 13:39:31 EDT
The latestest inter driver (xorg-x11-drv-i810-2.0.0-4.fc7) broke the VGA output
on my laptop's 945GM. I have 2 screens attached to the docking station one on
DVI (still works) and one on VGA which no longer works. There were issues with
dual screen but that's a different issue entirely!

The issue with the VGA seems to be mentioned in this mailing list thread
http://lists.freedesktop.org/archives/xorg/2007-June/025182.html and it looks
like it fixed it the latest git repo. So can we do another update to see if it
fixes the issues.
Comment 1 Matěj Cepl 2007-06-27 18:13:19 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Peter Robinson 2007-07-03 04:46:20 EDT
Created attachment 158412 [details]
xorg.log from xorg.conf

This is the log file from starting with a xorg.conf (config file attached next)
Comment 3 Peter Robinson 2007-07-03 04:47:09 EDT
Created attachment 158413 [details]

the xorg.conf to go with the log file
Comment 4 Peter Robinson 2007-07-03 04:49:10 EDT
Created attachment 158414 [details]
xorg.log from autodetect

attached is the x.org log from starting with no xorg.conf file
Comment 5 Peter Robinson 2007-07-03 04:51:01 EDT
Details provided. Let me know if you need any more info.
Comment 6 Fedora Update System 2007-07-06 14:11:14 EDT
xorg-x11-drv-i810-2.1.0-1.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
Comment 7 Matěj Cepl 2007-07-09 09:16:59 EDT
Actually, please, make note here even if the upgrade didn't help.
Comment 8 Peter Robinson 2007-07-11 10:02:05 EDT
It didn't work. I'm going to roll back to the original one that worked and get
the original log. then upgrade again.

The 2.1.0 driver all exhibits some interesting bits that weren't seen prev. If I
remove the xorg.conf file with the external screen attached it detects the
1280x1024 fine and starts up. If I then remove the laptop from the dock and
startup again (ie go home) just on my laptop screen (1440x900) it doesn't detect
it properly so you get the X doesn't start dialog do you want to configure it. I
spec the screen res and it starts fine. It did this with the prev version too
but the difference is that the previous version would clip the screen (IE the
screen seemed to be 1440 wide but only showed 1280 - you could loose the mouse
off the side) now its extremely flickery and you need to go to a console and rm
the xorg.conf and Ctrl+Alt+Bkspc to get it back.

When there's no xorg.conf file it also does weird things with the UK keyboard
but that's another bug entirely!
Comment 9 Matěj Cepl 2007-07-11 10:05:56 EDT
Before downgrading to the older driver, could we get an output of xrandr -q
command, please?
Comment 10 Peter Robinson 2007-07-11 10:07:58 EDT
[root@localhost ~]# xrandr -q
Screen 0: minimum 640 x 480, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 (normal left inverted right) 0mm x 0mm
   1280x1024      75.0* 
   1024x768       75.0  
   800x600        75.0  
   640x480        75.0  
[root@localhost ~]# 
Comment 11 Peter Robinson 2007-07-11 16:28:20 EDT
OK this is weird! As a follow on from my Comment #8 above when not docked I get
a totally different output. So to cover my setups a little better:

Dell D620 laptop with a 1440x900 14.1 inch display (there's 2 options when
ordering) and a Ddock replicator. Attached to the Ddock are 2 identical HP 19
inch LCD displays (one to the DVI port and one to the VGA port.

[root@localhost log]# lspci | grep 945GM
00:00.0 Host bridge: Intel Corporation Mobile 945GM/PM/GMS, 943/940GML and 945GT
Express Memory Controller Hub (rev 03)
00:02.0 VGA compatible controller: Intel Corporation Mobile 945GM/GMS,
943/940GML Express Integrated Graphics Controller (rev 03)
00:02.1 Display controller: Intel Corporation Mobile 945GM/GMS, 943/940GML
Express Integrated Graphics Controller (rev 03)
[root@localhost log]# 

At work when connected to the dock I run with the laptop closed off (in theory)
the 2 LCDs (works fine in windows). When elsewhere I run off the laptop display. 

When moving to the dock (working previously on the laptop 1440x900 display
moving 2 external lcds) I now get a buzzing static display (its recognizable but
it looks like its displaying the first 1280 and wrapping the remainder of the
1440). I remove the xorg.conf do a ctrl+alt+bkspc and it auto detects and away I
go (see xrandr above for output).

When moving from the dock (working previously on external lcd) to the built in
1440x900 I get X will not start (will attach logs shortly) and I have to go
through the config druid. It only detects 800x600 so I have to specify a
1440x900 generic LCD. It then starts as expected. The interesting part of this
is if you look through the TUI log files its using the i810 driver not the intel

Below is the xrandr for just the local laptop panel.... interesting that it sees
the vga etc now.... disconnected!

[root@localhost ~]# xrandr -q
Screen 0: minimum 320 x 200, current 1440 x 900, maximum 1440 x 1440
VGA disconnected (normal left inverted right)
LVDS connected 1440x900+0+0 (normal left inverted right) 304mm x 190mm
   1440x900       60.0*+
   1360x768       59.8     60.0  
   1280x800       60.0  
   1152x864       60.0  
   1280x768       60.0  
   1280x720       60.0  
   1024x768       60.0  
   800x600        60.3  
   640x480        59.9  
TMDS-1 disconnected (normal left inverted right)
TV disconnected (normal left inverted right)
[root@localhost ~]# 
Comment 12 Peter Robinson 2007-07-11 16:36:01 EDT
Created attachment 159001 [details]
laptop display no dock auto detect log

I had 2 different logs from during the "we can't start X process". One from the
initial startup and one from during the detection before manually specifying
the display resolution of 1440x900. Doing a diff on them just gave some
different hex addresses so they are the same.... so here's one for ref
Comment 13 Jesse Barnes 2008-01-10 18:08:30 EST
So does this still occur?  It sounds like you're sometimes using the i810 
driver, what happens if you always use the intel driver?
Comment 14 Peter Robinson 2008-01-11 04:54:38 EST
No I was always using the Intel driver (the i810 driver didn't detect the
1440x900 res of the laptop. Unfortunately I don't have this setup anymore as
I've changed jobs. The VGA screen disappeared between 2.0.0 and 2.1.0
Comment 15 Jesse Barnes 2008-01-11 12:31:23 EST
Ah ok.  Well there have been a few VGA detection fixes since 2.1.0, so this 
bug is probably fixed.  But it sounds like you can't test anymore so we should 
probably just close this bug.
Comment 16 Matěj Cepl 2008-01-14 05:08:08 EST
We don't do it -- we may eventually (for some inexplicable reason ;-)) actually
provide update for F7 and then it could get fixed. Otherwise it will get closed
together with all other F7 bugs when F7 will ceased to be supported.
Comment 17 Peter Robinson 2008-03-26 06:25:03 EDT
Closing this as I can't properly test it and the xorg-intel driver has changed
so much between when I reported this and what I'm running now (Fedora 9 rawhide
- basically F9 Beta).

Note You need to log in before you can comment on or make changes to this bug.