Bug 245979 - pata_it821x locks up the machine
pata_it821x locks up the machine
Status: CLOSED DUPLICATE of bug 242229
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-27 15:13 EDT by Stas Sergeev
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-28 16:10:17 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
lspci (7.02 KB, text/plain)
2007-06-27 15:13 EDT, Stas Sergeev
no flags Details
dmesg (23.23 KB, text/plain)
2007-06-27 15:14 EDT, Stas Sergeev
no flags Details

  None (edit)
Description Stas Sergeev 2007-06-27 15:13:05 EDT
Description of problem:
There is a PC with the ITE8212 raid controller,
to which the cd-rom is attached.
FC6 installed and worked without any problems
on this PC.
Trying to install F7 locks up the machine when
it is trying to load the pata_it821x driver.
We disabled the controller in bios setup to
install F7 anyway. Since the cdrom became disabled,
we booted from flash and did a network install.
After install, the problem didn't disappear.
The machine locks up on "Starting udev".
The only way to use F7 on this machine was to
add the pata_it821x to /etc/modprobe.d/blacklist
and live without a cdrom.

Version-Release number of selected component (if applicable):
kernel-2.6.21-1.3228.fc7

How reproducible:
Always

Steps to Reproduce:
1. Get the PC with the ITE8212 raid controller first.
2. Start the F7 installation
3. See the machine locked up when trying to load the driver
  
Actual results:
F7 installation freezes on start; F7 freezes on startup.

Expected results:
F7 installs; F7 boots; F7 works

Additional info:
The noraid option doesn't make any difference.
Actually, loading the pata_821x itself doesn't
lock up the machine, but loading sr_mod after it -
does. Still I think the problem is in the it821x
driver, but this is just a guess.
I'll attach the lspci and dmesg outputs.
The dmesg output is from the unupdated F7 kernel,
but the update released to that time, does not
solve the problem.
Comment 1 Stas Sergeev 2007-06-27 15:13:05 EDT
Created attachment 158043 [details]
lspci
Comment 2 Stas Sergeev 2007-06-27 15:14:02 EDT
Created attachment 158044 [details]
dmesg
Comment 3 Chuck Ebbert 2007-06-28 16:10:17 EDT

*** This bug has been marked as a duplicate of 242229 ***

Note You need to log in before you can comment on or make changes to this bug.