Bug 245992 - need new crash-devel package
need new crash-devel package
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: distribution (Show other bugs)
All Linux
medium Severity medium
: ---
: ---
Assigned To: RHEL Product and Program Management
Depends On:
  Show dependency treegraph
Reported: 2007-06-27 15:51 EDT by Dave Anderson
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHEA-2007-0854
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2007-11-07 11:42:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Dave Anderson 2007-06-27 15:51:10 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030611

Description of problem:

This RHEL5.1 bugzilla describes the requirement for a crash-devel
package for use by Systemtap:
  Bugzilla Bug 241045: need crash-devel package for building extensions

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Need new crash-devel package containing "/usr/include/crash/defs.h" file

Actual Results:

Expected Results:

Additional info:
Comment 2 Dave Anderson 2007-07-16 11:42:53 EDT
When filing the crash utility errata for RHEL5-1, it "found" the
crash-devel packages.  But they are not included in the file list,
and I don't know what supposed to be done to achieve this step.
Comment 3 Dave Anderson 2007-07-16 14:36:46 EDT
Sent the following request to release-engineering, returned as
ticket: [engineering.redhat.com #13977]

With respect to RHEL-5.1 errata RHBA-2007:0553:

  RHBA-2007:0553 - crash bug fix update

One of the approved bugzillas (241045) requires the addition of a new
"crash-devel" subpackage to the crash utility package.

When performing the "Update Brew Builds" step, upon entering the
following list:


and clicking "Find New Brew Builds", all packages are found, including
the new "crash-devel" packages:

  Updated Builds

  RHEL-5 has new builds

  Found Build# 62706 crash-4.0-4.3.1 with tag dist-5E-qu-candidate. RPMS in

However, the file list that gets saved does not include the
crash-devel packages, presumably because there's some other
previously-existing list/mechanism that that doesn't know
anything about the new crash-devel package.

Also, there is this bugzilla:

  Bugzilla Bug 245992: need new crash-devel package

Ben Levenson set these flags in that bugzilla:

   exception: ?
  rhel-5.1.0: ?
      pm_ack: ?
   devel_ack: ?
      qa_ack: +

What needs to be done to move this procedure along?

Dave Anderson

Comment 6 Dave Anderson 2007-07-16 16:22:07 EDT
I don't think that the distribution should be changed from "distribution"
to "crash".  

There already was a previously-existing "crash" component bugzilla for
this package update:

   Bugzilla Bug 241045: need crash-devel package for building extensions

And that bugzilla is the one listed in the errata's bugzilla list.

This bugzilla was specifically filed against "distribution" as requested
by Ben Levenson, so that they could track the comps-list update.
Comment 7 Dave Anderson 2007-07-16 16:37:48 EDT
> I don't think that the distribution should be changed from "distribution"
> to "crash

I meant to state that the *component* should not have been
changed from "distribution" to "crash".

Sue, can you change it back?
Comment 8 Dave Anderson 2007-07-18 10:04:09 EDT
OK, I am unilaterally changing it back to "distribution" and "pm-rhel".
Change it back if necessary, but all that does is duplicate the
original crash-utility bugzilla #241045 referenced in the Description

Currently the errata is temporarily being held up until release engineering
can address a problem where the ppc64 version of the crash-devel
package is not being picked up and included in the errata file list.
Dennis Gregorovic is working on fixing the problem -- here is his latest entry
in release-engineering ticket "[engineering.redhat.com #13977] additional
package request: crash-devel for crash utility":

>>  > TPSERROR: crash-devel-4.0-4.3.1.ppc64.rpm was built by 
>> crash-4.0-4.3.1.src.rpm > but not included in the file list
>>  > Please check prior releases to ensure the file list is sane.
>>  > List of Built Packages:
>>  > /usr/src/redhat/RPMS/ppc64/crash-4.0-4.3.1.ppc64.rpm
>>  > /usr/src/redhat/RPMS/ppc64/crash-devel-4.0-4.3.1.ppc64.rpm
>>  > /usr/src/redhat/RPMS/ppc64/crash-debuginfo-4.0-4.3.1.ppc64.rpm
>> And it's not a false alarm -- for some reason the ppc64 version
>> of the crash-devel package was not picked up even though it
>> exists in the build tree:

I've fixed up the data in the db so that it's picking up the signed 
packages.  I then moved the advisory to ON_RHNQA and tried the push 
to QA.  Unfortunately, it failed because the beta-signed versions of 
these packages are already there and it's causing a conflict.  Fixing 
this requires clearing the beta-signed packages, but I need to work 
with prod ops to take care of that.  I'll try to get to that today, 
but I can't say for sure.  So, at this point the ball is in my court.

-- Dennis

Comment 9 Dave Anderson 2007-07-24 09:42:22 EDT
This bugzilla has been resolved.

The RHEL5.1 crash errata is now in HOLD_UPDATE state,
and all of its associated bugzillas in RELEASE_PENDING:


Comment 13 errata-xmlrpc 2007-11-07 11:42:28 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.


Note You need to log in before you can comment on or make changes to this bug.