This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 246003 - CPIO error writing to tape on files larger than 7gb.
CPIO error writing to tape on files larger than 7gb.
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: cpio (Show other bugs)
4.5
i386 Linux
low Severity low
: ---
: ---
Assigned To: Radek Brich
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-27 16:09 EDT by Ron Angel
Modified: 2008-07-28 00:24 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-29 07:41:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ron Angel 2007-06-27 16:09:49 EDT
Description of problem:
CPIO error writing to tape on files larger than 7gb. We have 2 large files in
our backup:  The first file is 7gb in size and the other is 35gb in size.  cpio
generates errors on both files. I removed the first file and it then resulted
with the same error on the second file.

"cpio -oc --block-size=16MB >/dev/st0 </file_list"


Version-Release number of selected component (if applicable):
cpio-2.5-13.RHEL4

How reproducible:
This has occurred daily using a script.  The specific script portion using cpio
is noted in step one below.  The "file_list" is a flat file from a find command.


Steps to Reproduce:
1.cpio -oc --block-size=16MB >/dev/st0 </file_list
2."cpio field width not sufficient for storing file size" results on the large files
3. Backup runs a few more minutes and then hits the "end of tape" too soon
  
Actual results:


Expected results:


Additional info:
Comment 1 Radek Brich 2007-06-29 07:41:35 EDT
Size of files stored in cpio archive is limited to 4 GiB. Larger files are skipped.

You can use another archive type, like tar, which supports files up to 64 GiB.
Comment 2 Andrew Furey 2008-07-28 00:24:26 EDT
From the source it looks like it was part of the writeOutHeaderBufferOverflow patch.

I'm reverting to cpio-2.5-9.RHEL4 for now, as it has no such limit. Why was this
changed? 4 GiB seems to be a horribly low limit for an archive tool...

Note You need to log in before you can comment on or make changes to this bug.