Bug 246004 - fftw: epel branch/builds, rpmforge compatible
fftw: epel branch/builds, rpmforge compatible
Status: CLOSED ERRATA
Product: Fedora EPEL
Classification: Fedora
Component: fftw (Show other bugs)
el5
All Linux
low Severity low
: ---
: ---
Assigned To: Rex Dieter
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-27 16:24 EDT by Quentin Spencer
Modified: 2007-07-12 12:59 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-12 12:59:43 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Quentin Spencer 2007-06-27 16:24:02 EDT
Package Change Request
======================
Package Name: fftw
New Branches: EL-5
Comment 1 Kevin Fenzi 2007-06-28 15:26:37 EDT
I see that this package already has a EL-4 branch and rdieter@math.unl.edu is
listed as maintainer for EPEL. 

I went ahead and made the branch. Let me know if any other changes are needed.
Comment 2 Quentin Spencer 2007-06-28 15:32:48 EDT
That's correct; I should have thought to contact the existing maintainer.
Anyway, I need an fftw version >=3 to support octave in EPEL. The version in the
EL-5 branch is fftw 2. rdeiter, do you object to my putting version 3 in the
EL-5 branch?
Comment 3 Rex Dieter 2007-06-28 16:24:49 EDT
Sure, I'd like to coordinate compatibility with rpmforge.  They have *strong*
feelings that fftw version 3 should be named fftw3.

I don't care strongly one way or the other, so I was planning on doing it that
way, just haven't gotten round-tuit yet.
Comment 4 Rex Dieter 2007-06-28 19:31:12 EDT
I'll be away at akademy for the next week, and will likely have little time.

I'm ok with someone else building this for epel, provided they:
* make it named fftw3
* convince me soundly that naming it fftw3 is a bad idea, and build it named
fftw (like devel/ branch).
Comment 5 Orion Poplawski 2007-06-29 11:55:06 EDT
Gahh, I hate this kind of stuff:

- Isn't this backwards to what one usually does - name the latest version
without the major version and the older ones with it?  What happens when fttw 4
comes out?  The names get even sillier.

- Although, in this case, the libraries in fftw 3.x are actually called
libfftw3..  so in some sense it is upstream being silly too (though the tarball
is just fftw-3.X)

- Finally, I really just want fftw 3.X, and can't really get worked up about
what it's called.  I'll make the necessary change in the BR and leave it
(hopefully) forever.  Will get confused sometimes though comparing my EL systems
to my Fedora systems...


Comment 6 Rex Dieter 2007-07-12 11:31:46 EDT
FYI, builds queue'd.  Please test for sanity:
EL-4: http://buildsys.fedoraproject.org/build-status/job.psp?uid=34938
EL-5: http://buildsys.fedoraproject.org/build-status/job.psp?uid=34937

fwiw, even fedora's builds include
Provides: fftw3
and
Provides: fftw3-devel

So using, BuildRequires: fftw3-devel
should work everywhere.
Comment 7 Rex Dieter 2007-07-12 12:59:43 EDT
At knurd's suggestion, added Provides, appears safe in my own testing...

* Thu Jul 12 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.1.2-5
- fftw3(-devel): Provides: fftw(-devel) = %version ...
- cleanup, +%check section (disabled by default)

* Tue Jul 10 2007 Rex Dieter <rdieter[AT]fedoraproject.org> 3.1.2-4
- (re)name -> fftw3 (epel-only, for rpmforge compatibility, #246004)


builds queue'd, closing->errata.  
Enjoy.

Note You need to log in before you can comment on or make changes to this bug.