Bug 246029 - Printer operation policy not set on service start / restart / reload
Printer operation policy not set on service start / restart / reload
Status: CLOSED DUPLICATE of bug 246027
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
6
i386 Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-27 18:37 EDT by Opher Shachar
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-27 18:40:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
CUPS Bugs and Features 2319 None None None Never

  None (edit)
Description Opher Shachar 2007-06-27 18:37:04 EDT
Description of problem:
When the CUPS service is started or restarted or reloaded printer operation 
policies are not set (they are left 'default').

Version-Release number of selected component (if applicable):
1.2.7

How reproducible:
Always.

Steps to Reproduce:
1. service cups restart / start / reload
2. lpadmin -p myprinter -o printer-op-policy=foo
3. Policy takes affect.
4. service cups restart / start / reload
5. Policy for myprinter was reset to 'default'
  
Actual results:
Unlike the report in CUPS STR #2319 a reload does *not* preserve or loads 
printer operation policies.

Expected results:


Additional info:
This script, placed in /etc/init.d/cups, can workaround this.

while read tag printer; do
    [[ "$tag" != "<Printer" ]] && continue
    printer=${printer%>}
    while read tag value; do
        [[ "$tag" == "</Printer>" ]] && break
        [[ "$tag" != "OpPolicy" ]] && continue
        echo "lpadmin -p $printer -o printer-op-policy=$value"
        lpadmin -p $printer -o printer-op-policy=$value
    done
done < /etc/cups/printers.conf
Comment 1 Opher Shachar 2007-06-27 18:40:52 EDT

*** This bug has been marked as a duplicate of 246027 ***

Note You need to log in before you can comment on or make changes to this bug.