Bug 246037 - Fails unpacking package, but reports success
Fails unpacking package, but reports success
Status: CLOSED DUPLICATE of bug 186945
Product: Fedora
Classification: Fedora
Component: rpm (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Paul Nasrat
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-27 20:28 EDT by Boris Goldowsky
Modified: 2014-01-21 17:58 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-10 03:05:41 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Boris Goldowsky 2007-06-27 20:28:56 EDT
This package has been failing to update, but yum reports success.  Pup attempts
to update it over and over, always claiming to have done so.  Command line yum
shows this:

$ sudo yum update
Password:
Loading "installonlyn" plugin
Loading "fastestmirror" plugin
Loading mirror speeds from cached hostfile
Setting up Update Process
Resolving Dependencies
--> Running transaction check
---> Package java-1.5.0-gcj-javadoc.x86_64 0:1.5.0.0-14.fc7 set to be updated

Dependencies Resolved

=============================================================================
 Package                 Arch       Version          Repository        Size 
=============================================================================
Installing:
 java-1.5.0-gcj-javadoc  x86_64     1.5.0.0-14.fc7   fedora            5.2 M
     replacing  java-1.4.2-gcj-compat-javadoc.x86_64 1.4.2.0-40jpp.110


Transaction Summary
=============================================================================
Install      1 Package(s)         
Update       0 Package(s)         
Remove       0 Package(s)         

Total download size: 5.2 M
Is this ok [y/N]: y
Downloading Packages:
(1/1): java-1.5.0-gcj-javadoc-1.5.0.0-14.fc7.x86_64.rpm         5.2 MB 00:11 
Running Transaction Test
Finished Transaction Test
Transaction Test Succeeded
Running Transaction
  Installing: java-1.5.0-gcj-javadoc       ######################### [1/2] 
error: unpacking of archive failed on file /usr/share/javadoc/java: cpio: rename

Installed: java-1.5.0-gcj-javadoc.x86_64 0:1.5.0.0-14.fc7
Replaced: java-1.4.2-gcj-compat-javadoc.x86_64 0:1.4.2.0-40jpp.110
Complete!

But it really failed:

$ rpm -qa | grep javadoc
java-1.4.2-gcj-compat-javadoc-1.4.2.0-40jpp.110.x86_64
Comment 1 Jeff Johnson 2007-07-05 08:24:53 EDT
You are likely trying to replace a directory with a symlink.

If so, you will need to add a %pretrans section to move the directory and
create the symlink. tar/cpio have exactly the same problem as rpm replacing
a directory with a symlink.
Comment 2 Panu Matilainen 2007-08-10 03:05:41 EDT

*** This bug has been marked as a duplicate of 186945 ***

Note You need to log in before you can comment on or make changes to this bug.