Bug 246040 - can not use programs as root from user account
can not use programs as root from user account
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: fedora-usermgmt (Show other bugs)
7
All Linux
low Severity low
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-27 20:41 EDT by ashley pritchard
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-16 18:00:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description ashley pritchard 2007-06-27 20:41:36 EDT
Description of problem:
can not run programs that require root access from user account

Version-Release number of selected component (if applicable):
Fedora 7

How reproducible:


Steps to Reproduce:
1. login as user 
2. try to run a program as root
3. try to run program as root from terminal
  
Actual results:
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

Traceback (most recent call last):
File "/usr/sbin/pup", line 31, in <module>
import gtk
File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 76, in
<module>
_init()
File "/usr/lib/python2.5/site-packages/gtk-2.0/gtk/__init__.py", line 64, in _init
_gtk.init_check()
RuntimeError: could not open display

Expected results:
to be able to run the desired program that requires root access 

Additional info:
[awp@localhost ~]$ xhost +localhost
localhost being added to access control list
[awp@localhost ~]$ su root
Password:
[root@localhost awp]# xhost +localhost
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

xhost: unable to open display ":0.0"
[root@localhost awp]# kdesu pup
Xlib: connection to ":0.0" refused by server
Xlib: No protocol specified

kdesu: cannot connect to X server :0.0

awp@localhost ~]$ xhost
access control enabled, only authorized clients can connect
SI:localuser:awp
[awp@localhost ~]$ xhost +localhost
localhost being added to access control list
[awp@localhost ~]$ env | grep
Usage: grep [OPTION]... PATTERN [FILE]...
Try `grep --help' for more information. 

awp@localhost ~]$ ll /usr/sbin/userhelper
-rws--x--x 1 root root 34060 2007-06-15 01:56 /usr/sbin/userhelper

[root@localhost ~]# cd /var/log/gdm
[root@localhost gdm]# ls -l
total 36
-rw-r--r-- 1 root root 1049 2007-06-27 08:32 : 0.log
-rw-r--r-- 1 root root 1143 2007-06-27 08:31 :0.log.1
-rw-r--r-- 1 root root 1076 2007-06-27 08:21 :0.log.2
-rw-r--r-- 1 root root 1230 2007-06-27 08:10 :0.log.3
-rw-r--r-- 1 root root 1076 2007-06-27 07:52 :0.log.4
-rw-r--r-- 1 root root 1095 2007-06-23 22:07 : 20.log
-rw-r--r-- 1 root root 1095 2007-06-23 22:04 :20.log.1
Comment 1 Enrico Scholz 2007-06-28 16:14:19 EDT
are you really sure that this is the right component?
Comment 2 ashley pritchard 2007-06-28 18:01:20 EDT
(In reply to comment #1)
> are you really sure that this is the right component?
no i am not sure it is the correct component at all.

Comment 3 ashley pritchard 2007-06-30 23:43:34 EDT
OK I was at work today & was thinking about what I was doing before my problem
of not being able to run programs as root from my user acct & did a little bit
of research on the issue.
In this process I cam over the suggestion to edit /root/.bashrc & add: export
XAUTHORITY= /home/awp/.Xauthority so I did.
The result was: export '/home/awp/.Xauthority': not a valid identifier
The next suggestion I found was to use the command '-d' which just did not work
at all because it was not recognized at all.
Then the next suggestion was to use xhost to verify that it is set to permit
connections from machine. The result was:
access control enabled, only autherized clients can connect
INET: localhost.localdomane
SI: localuser:awp

Then the next suggestion I found was back to 'xhost +localhost' before useing su
to log in to root & then doing 'export DISPLAY=:0' aft loging in as root. Well
this did not work better that the last time I used the command xhost +localhost.
Then I found another suggestion which is to use the command 'xauth merge
/home/awp/.Xauthority'
The result:
xauth merge /home/awp/.Xauthority
xauth: creating new authority file /home/awp/.Xauthority
xauth: (argv):1: merge: unable to open file /home/awp/.Xauthority

So none of the suggestions seem that I could find seemed to work for me & the
last suggestion was to uninstall & reinstall X. I did not want to do this so I
started thinking & recalling what exactly I did before this issue occurred.
Other than installing DVD & mp3 support I was messing with xnest attempting to
open GDM in a nested window so that I could graphically login as root via my
user account. So I uninstalled xorg-x11-server-xnest but that did not resolve my
issue.

Then I remembered that I had changed my intel integrated graphics driver from
the  'Intel - Experimental mode setting driver for Intel integrated graphics
chipsets' to  the 'i810 intel integrated graphics chipset including i810, i815,
830m, 845G, 852GM, 865G, 915G, 915GM, 945GM'. So I switched the graphics driver
back the the 'experimental' driver. That did not work either.

Then I had found a file /root/.bash_history which contains the history of bash
commands made in the terminal. A series of commands that I had entered jarred my
memory. I was attempting to get another desktop manager installed call
Enlightenment & int the process one of the dependencies was XFree86. When I
attempted to install XFree86  it required several directories to be created:
/usr/X11R6/bin/mkfontdir and /usr/X11R6/bin/xauth so I had created those
directories. And that is when thiss issue started occurring.

SO THE SOLUTION TO MY ISSUE: was to delete /X11R6/bin/xauth & /mkfontdir in the
/usr directory.
Now I am able to use su root to login as root from my user account once again so
that I can use programs that require root.

Thanks for all the attempts to help me.

THIS IS NOT A BUG....SORRY

Note You need to log in before you can comment on or make changes to this bug.