Bug 246048 - FC7 can not be installed by IDE cdrom
FC7 can not be installed by IDE cdrom
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-27 22:35 EDT by bibo,mao
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 02:51:50 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch, cleaned up and submitted to linux-ide list (821 bytes, patch)
2007-06-28 15:18 EDT, Chuck Ebbert
no flags Details | Diff

  None (edit)
Description bibo,mao 2007-06-27 22:35:27 EDT
Description of problem:
FC7 can not be installed on my santa-rosa platform from ide CDROM, it can only
be installed by NFS method. But RHEL5 can be installed from ide CDROM.

Here is my pci device list by lspci and lspci -n command

00:1e.0 PCI bridge: Intel Corporation 82801 Mobile PCI Bridge (rev f3)
00:1f.0 ISA bridge: Intel Corporation Mobile LPC Interface Controller (rev 03)
00:1f.1 IDE interface: Intel Corporation Mobile IDE Controller (rev 03)
00:1f.2 SATA controller: Intel Corporation Mobile SATA AHCI Controller (rev 03)
00:1f.3 SMBus: Intel Corporation 82801H (ICH8 Family) SMBus Controller (rev 03)
00:1f.4 Performance counters: Intel Corporation Unknown device 284e (rev 03)
02:00.0 Network controller: Intel Corporation Unknown device 4229 (rev 61)

00:1e.0 0604: 8086:2448 (rev f3)
00:1f.0 0601: 8086:2811 (rev 03)
00:1f.1 0101: 8086:2850 (rev 03)
00:1f.2 0106: 8086:2829 (rev 03)
00:1f.3 0c05: 8086:283e (rev 03)
00:1f.4 1101: 8086:284e (rev 03)
02:00.0 0280: 8086:4229 (rev 61)

I checked FC7 kernel source code, libata and ata_piix is for ide/sata device,
but ICH8M IDE controller(8086:2850) is not listed in file ata_piix.c.
So FC7 can not identify my ide cdrom
Comment 1 bibo,mao 2007-06-28 05:28:44 EDT
Someone else has post one patch in LKML, it works for me. The IDE cdrom can by 
identified with this patch.
  http://groups.google.com/group/fa.linux.kernel/msg/6c4bd453bfc4ac82

thanks
bibo,mao
Comment 2 Chuck Ebbert 2007-06-28 15:18:57 EDT
Created attachment 158154 [details]
patch, cleaned up and submitted to linux-ide list
Comment 3 Chuck Ebbert 2007-06-29 12:51:06 EDT
Patch went in kernel 1.3240.fc7
Comment 4 Thorsten Leemhuis 2007-07-06 13:04:58 EDT
(In reply to comment #3)
> Patch went in kernel 1.3240.fc7

Chuck, did you add it to F-7 only on purpose? 

Seems the patch is sill being discussed on linux-ide and looks like it won't
make it into 2.6.22, so might make sense to add it to the devel branch temporary
as well.
Comment 5 Chuck Ebbert 2007-07-06 13:18:17 EDT
(In reply to comment #4)
> Seems the patch is sill being discussed on linux-ide and looks like it won't
> make it into 2.6.22, so might make sense to add it to the devel branch temporary
> as well.

Done.
Comment 6 bibo,mao 2007-07-19 21:11:47 EDT
Now the patch has already in linus git tree, I think it can be added into FC7 
update kernel and future FC8 test version.
This patch is critical for us, without this patch FC7 can not be installed from 
Santa-Rosa DVD cdrom, and DVD cdrom can not be identified even FC7 is installed 
from network.
Comment 7 Thorsten Leemhuis 2007-07-20 00:44:01 EDT
(In reply to comment #6)
> Now the patch has already in linus git tree, I think it can be added into FC7 
> update kernel 

It's part of the testing kernel already

> and future FC8 test version.

As those are based on linus' git tree ATM it's part of that as well

> This patch is critical for us, without this patch FC7 can not be installed from 
> Santa-Rosa DVD cdrom, and DVD cdrom can not be identified even FC7 is installed 
> from network.

If you/Intel want to help it would be nice if you could clarify if the recent
ICH's support Ultras/ATA 133 or not

See the thread on LKML starting at
http://www.uwsg.indiana.edu/hypermail/linux/kernel/0707.0/0264.html

See also
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=blob;f=drivers/ata/ata_piix.c;h=d9fa329fd157741f12b83be996e8b7d419052044;hb=HEAD

According to that code the ICH5 and ICH7/7R support Ultra/ATA 133, but that's
not the case afaics from the datasheets.
Comment 8 Dave Jones 2007-10-11 02:51:50 EDT
should be fixed in devel tree, and forthcoming F7 2.6.23 update.

Note You need to log in before you can comment on or make changes to this bug.