Bug 246077 - Newer package not recognized: When file-4.17-9.0.1.el5 is installed, file-4.17-9.el5 is still shown as available for upgrade
Newer package not recognized: When file-4.17-9.0.1.el5 is installed, file-4.1...
Status: CLOSED NOTABUG
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Client (Show other bugs)
500
All Linux
medium Severity low
: ---
: ---
Assigned To: Pradeep Kilambi
Brandon Perkins
https://sputnik-prod.brq.redhat.com/r...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-06-28 08:16 EDT by Jan Pazdziora
Modified: 2007-07-12 11:01 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-07-12 06:00:24 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screenshot of the Upgrade page. (187.62 KB, image/png)
2007-06-28 08:16 EDT, Jan Pazdziora
no flags Details

  None (edit)
Description Jan Pazdziora 2007-06-28 08:16:35 EDT
Description of problem:

I have a system which has the package

  # rpm -q file
  file-4.17-9.0.1.el5.x86_64

installed. There is a package file-4.17-9.el5 in the channel, and the WebUI
shows that package as a possible target for upgrade. This does not sound correct.

Version-Release number of selected component (if applicable):

Satellite 5.0.0

How reproducible:

Tried once.

Steps to Reproduce:
1. Have a system registered to the RHEL 5 (Client) channel.
2. Install the file-4.17-9.0.1.el5 package.
3. Check the Software -> Packages -> Upgrade page.
  
Actual results:

Latest Package 	 file-4.17-9.el5
Installed Package   file-4.17-9.0.1.el5

Expected results:

The file package should not be shown.

Additional info:

I'd argue that the package file-4.17-9.0.1.el5 is newer/later than the
file-4.17-9.el5.

See attachment with the screenshot.

Also, yum check-update does the right thing and does not show file as a package
to be upgraded.

Note that there is the same problem with libX11 or libXfont. Basically we seem
not to be handling the x.0.y revisions correctly.
Comment 1 Jan Pazdziora 2007-06-28 08:16:36 EDT
Created attachment 158112 [details]
Screenshot of the Upgrade page.
Comment 2 Jan Pazdziora 2007-07-12 06:00:24 EDT
This is not a bug -- the problem was caused by us missing to upgrade the rpm
package body with the satellite-4.2.0-4-to-4.2.1-2.sql.

Note You need to log in before you can comment on or make changes to this bug.